Page MenuHomePhabricator

Missing or wrong information in meta_p.wiki table
Closed, ResolvedPublic

Description

+----------------------+------+------+-------------+-----------------------------------+------+-----------+-----------+----------+-----------------+------------------+--------------+
| dbname               | lang | name | family      | url                               | size | slice     | is_closed | has_echo | has_flaggedrevs | has_visualeditor | has_wikidata |
+----------------------+------+------+-------------+-----------------------------------+------+-----------+-----------+----------+-----------------+------------------+--------------+
| bat_smgwiki          | en   | NULL | wikipedia   | http://bat_smg.wikipedia.org      |    1 | s3.labsdb |         0 |        0 |               0 |                1 |            1 |
| be_x_oldwiki         | en   | NULL | wikipedia   | http://be_x_old.wikipedia.org     |    1 | s3.labsdb |         0 |        0 |               0 |                1 |            1 |
| cbk_zamwiki          | en   | NULL | wikipedia   | http://cbk_zam.wikipedia.org      |    1 | s3.labsdb |         0 |        0 |               0 |                1 |            1 |
| centralauth          | en   | NULL | centralauth | NULL                              |    1 | s7.labsdb |         0 |        0 |               0 |                0 |            0 |
| fiu_vrowiki          | en   | NULL | wikipedia   | http://fiu_vro.wikipedia.org      |    1 | s3.labsdb |         0 |        0 |               0 |                1 |            1 |
| map_bmswiki          | en   | NULL | wikipedia   | http://map_bms.wikipedia.org      |    1 | s3.labsdb |         0 |        0 |               0 |                1 |            1 |
| nds_nlwiki           | en   | NULL | wikipedia   | http://nds_nl.wikipedia.org       |    1 | s3.labsdb |         0 |        0 |               0 |                1 |            1 |
| roa_rupwiki          | en   | NULL | wikipedia   | http://roa_rup.wikipedia.org      |    1 | s3.labsdb |         0 |        0 |               0 |                1 |            1 |
| roa_rupwiktionary    | en   | NULL | wiktionary  | http://roa_rup.wiktionary.org     |    1 | s3.labsdb |         0 |        0 |               0 |                0 |            0 |
| roa_tarawiki         | en   | NULL | wikipedia   | http://roa_tara.wikipedia.org     |    1 | s3.labsdb |         0 |        0 |               0 |                1 |            1 |
| vewikimedia          | en   | NULL | wikimedia   | http://ve.wikimedia.org           |    1 | s3.labsdb |         0 |        0 |               0 |                0 |            0 |
| zh_classicalwiki     | en   | NULL | wikipedia   | http://zh_classical.wikipedia.org |    1 | s3.labsdb |         0 |        0 |               1 |                1 |            1 |
| zh_min_nanwiki       | en   | NULL | wikipedia   | http://zh_min_nan.wikipedia.org   |    1 | s3.labsdb |         0 |        0 |               0 |                1 |            1 |
| zh_min_nanwikibooks  | en   | NULL | wikibooks   | http://zh_min_nan.wikibooks.org   |    1 | s3.labsdb |         0 |        0 |               0 |                0 |            0 |
| zh_min_nanwikiquote  | en   | NULL | wikiquote   | http://zh_min_nan.wikiquote.org   |    1 | s3.labsdb |         0 |        0 |               0 |                0 |            0 |
| zh_min_nanwikisource | en   | NULL | wikisource  | http://zh_min_nan.wikisource.org  |    1 | s3.labsdb |         0 |        0 |               0 |                0 |            0 |
| zh_min_nanwiktionary | en   | NULL | wiktionary  | http://zh_min_nan.wiktionary.org  |    1 | s3.labsdb |         0 |        0 |               0 |                0 |            0 |
| zh_yuewiki           | en   | NULL | wikipedia   | http://zh_yue.wikipedia.org       |    1 | s3.labsdb |         0 |        0 |               0 |                1 |            1 |
+----------------------+------+------+-------------+-----------------------------------+------+-----------+-----------+----------+-----------------+------------------+--------------+

For the wikis reported above lang is 'en', name in NULL and URL is wrong (maybe this is the reason for the other missing information). For example isn't http://roa_tara.wikipedia.org but http://roa-tara.wikipedia.org

For all the wikis, 'size' column is always 1. This information can be get from:

  • site_stats.ss_good_articles table of replica db, or
  • API /w/api.php?action=query&meta=siteinfo&format=json&siprop=statistics under "articles"

Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=48626

Details

Reference
bz54962

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 2:11 AM
bzimport added a project: Toolforge.
bzimport set Reference to bz54962.
Beta16 created this task.Oct 4 2013, 9:46 AM
coren added a comment.Oct 4 2013, 1:09 PM

Yes, the URL being incorrect is likely the cause of the other errors. Looking into it.

Beta16 added a comment.Oct 9 2013, 1:42 PM

Also 'is_closed' column is always 0, for all the wikis.

coren added a comment.Oct 9 2013, 1:55 PM

(In reply to comment #2)

Also 'is_closed' column is always 0, for all the wikis.

That would be because we do not currently replicate any closed wikis. :-)

For the other values, things should have been corrected now. Please check?

Beta16 added a comment.Oct 9 2013, 3:50 PM

(In reply to comment #3)

(In reply to comment #2)

Also 'is_closed' column is always 0, for all the wikis.

That would be because we do not currently replicate any closed wikis. :-)

Ah, ok! Alright :)

For the other values, things should have been corrected now. Please check?

Now it seems ok, except for the 'size' column, is always 1 yet.

coren added a comment.May 6 2014, 2:13 AM

There was a typo that prevented the size column from being properly set. Fixed since.

The meta_p.wiki tables now contains only one row: centralauth.

MariaDB [meta_p]> select * from wiki;
+-------------+------+------+-------------+------+------+-----------+-----------+----------+-----------------+------------------+--------------+

dbnamelangnamefamilyurlsizesliceis_closedhas_echohas_flaggedrevshas_visualeditorhas_wikidata

+-------------+------+------+-------------+------+------+-----------+-----------+----------+-----------------+------------------+--------------+

centralauthenNULLcentralauthNULL1s7.labsdb00000

+-------------+------+------+-------------+------+------+-----------+-----------+----------+-----------------+------------------+--------------+
1 row in set (0.00 sec)

Now the problem seems to be fixed.

Change 160945 had a related patch set uploaded by coren:
Labs: Fix generation of meta_p.meta

https://gerrit.wikimedia.org/r/160945

Change 160945 merged by coren:
Labs: Fix generation of meta_p.meta

https://gerrit.wikimedia.org/r/160945

coren moved this task from Triage to Backlog on the Toolforge board.Nov 25 2014, 4:17 PM
scfc added a comment.Feb 18 2015, 7:28 PM

At the moment, there are two wikis apart from centralauth that have name set to NULL:

MariaDB [enwiki_p]> SELECT * FROM meta_p.wiki WHERE name IS NULL;
+-------------+------+------+-------------+------------------------------+------+-----------+-----------+----------+-----------------+------------------+--------------+
| dbname      | lang | name | family      | url                          | size | slice     | is_closed | has_echo | has_flaggedrevs | has_visualeditor | has_wikidata |
+-------------+------+------+-------------+------------------------------+------+-----------+-----------+----------+-----------------+------------------+--------------+
| qualitywiki | en   | NULL | special     | http://quality.wikimedia.org |    1 | s3.labsdb |         1 |        1 |               0 |                0 |            0 |
| centralauth | en   | NULL | centralauth | NULL                         |    1 | s7.labsdb |         0 |        0 |               0 |                0 |            0 |
| ukwikimedia | en   | NULL | wikimedia   | http://uk.wikimedia.org      |    1 | s3.labsdb |         1 |        1 |               0 |                0 |            0 |
+-------------+------+------+-------------+------------------------------+------+-----------+-----------+----------+-----------------+------------------+--------------+
3 rows in set (0.00 sec)

MariaDB [enwiki_p]>

As these are closed wikis I assume that is correct?

Also, there are no wikis with size not being 1:

MariaDB [enwiki_p]> SELECT size, COUNT(*) FROM meta_p.wiki GROUP BY size;
+------+----------+
| size | COUNT(*) |
+------+----------+
|    1 |      858 |
+------+----------+
1 row in set (0.00 sec)

MariaDB [enwiki_p]>

Is this column important to you, @Pietrodn? Otherwise I'd propose to resolve this task as the main issues seem to have been fixed.

jayvdb added a subscriber: jayvdb.Feb 19 2015, 10:17 PM

Is T69476 part of the scope of this task?

scfc closed this task as Resolved.Feb 20 2015, 4:00 AM

Is T69476 part of the scope of this task?

No, that should be handled there.

Regarding the size column, looking at maintain-replicas.pl showed that it should not be 1 for all wikis, so I filed T90084 for that.

I close this task as its original bug has been fixed.

Ricordisamoa updated the task description. (Show Details)Jul 26 2015, 1:09 AM
Ricordisamoa set Security to None.
Ricordisamoa added a subscriber: Ricordisamoa.
Restricted Application added a project: Cloud-Services. · View Herald TranscriptJul 26 2015, 1:09 AM