Autoconfirm users on import
Closed, DeclinedPublic

Description

Users should still be autoconfirmed after being imported if they meet the requirements on the new wiki.

Just add it to the user_groups table or something?


Version: master
Severity: normal

Details

Reference
bz55656
bzimport raised the priority of this task from to Lowest.
bzimport set Reference to bz55656.
bzimport added a subscriber: Unknown Object (MLST).
Isarra created this task.Oct 12 2013, 5:46 PM
Skizzerz closed this task as Declined.Dec 3 2017, 5:31 PM
Skizzerz added a subscriber: Skizzerz.

The user's registration date and edit count are maintained on import, and existing edits are reattributed (so the maint script which recounts edits won't wipe things). As such, if they meet autoconfirmed criteria on the new wiki, they should be receiving it automatically. I see no reason and have no desire to manually add autoconfirmed as an explicit group in the db due to this.