Page MenuHomePhabricator

the message that shows the number of sources for a statement seems to use PLURAL incorrectly
Closed, ResolvedPublic

Description

A statement has a list of sources. When there is one source for a statement, then the Hebrew translation of the message that shows the number 1 before the word "source", which is incorrect - "1" must come after number and other numbers come before. I suspect that the message is "lego" - concatenating the number and the word "source" instead of using message functions to formulate it properly.

Details

Reference
bz55961
Related Gerrit Patches:
mediawiki/extensions/Wikibase : masterImprove sitelinks and references counter messages

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 2:21 AM
bzimport set Reference to bz55961.
bzimport added a subscriber: Unknown Object (MLST).
Amire80 created this task.Oct 21 2013, 8:40 AM

You can translate [[translatewiki:MediaWiki:Wikibase-statementview-referencesheading-pendingcountersubject/he]] and [[translatewiki:MediaWiki:Wikibase-ui-pendingquantitycounter-nonpending/he]].

Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
adrianheine closed this task as Invalid.Mar 10 2015, 10:28 AM
adrianheine claimed this task.
adrianheine added a subscriber: adrianheine.

I don't think this is a code issue either, doesn't look like lego to me.

Amire80 reopened this task as Open.Mar 10 2015, 10:41 AM

Sorry, no, it is very much an issue. Wikibase-statementview-referencesheading-pendingcountersubject is reused in Wikibase-ui-pendingquantitycounter-nonpending, and this makes it untranslatable to Hebrew, and possibly other languages.

It may seem counter-intuitive to programmers to repeat the same words in more than one message, but in localization this is OK.

You're right, it's like this:

wikibase-ui-pendingquantitycounter-nonpending and wikibase-ui-pendingquantitycounter-pending are basically called with

$1: wikibase-propertyedittool-counter-entrieslabel, $2: n, $3: "<span title="wikibase-propertyedittool-counter-pending-tooltip">wikibase-ui-pendingquantitycounter-pending-pendingsubpart</span>

and

$1: wikibase-statementview-referencesheading-pendingcountersubject, $2: n, $3: "<span title="wikibase-statementview-referencesheading-pendingcountertooltip">wikibase-ui-pendingquantitycounter-pending-pendingsubpart</span>

How would we best solve this? Is T72838 a duplicate of this?

Yes, T72838 is closely related and offers a solution.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 15 2015, 3:13 AM

Change 281932 had a related patch set uploaded (by Adrian Heine):
Improve sitelinks and references counter messages

https://gerrit.wikimedia.org/r/281932

Change 281932 merged by jenkins-bot:
Improve sitelinks and references counter messages

https://gerrit.wikimedia.org/r/281932

adrianheine closed this task as Resolved.Apr 13 2016, 10:00 AM
adrianheine moved this task from Review to Done on the Wikidata-Sprint-2016-04-12 board.