Page MenuHomePhabricator

Contributor pages which show user name but not any other data should include an explanation
Closed, ResolvedPublic

Description

404 errors for jquery 1.7.1

The attached screenshot shows what I see when I visit
http://korma.wmflabs.org/browser/people.html?id=1073&name=bugzilla.wikimedia


Version: unspecified
Severity: normal

Attached:

404_errors_for_jquery_1.7.1.png (900×1 px, 122 KB)

Details

Reference
bz56111

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 2:31 AM
bzimport set Reference to bz56111.
bzimport added a subscriber: Unknown Object (MLST).

Hi Helge,

Those fails for files are normal. Right now we are trying to get JSON files to see if the information is available. For this person (bugzilla.wikimedia) there is no information (because this contributors is not in the top people which data is generated).

For example, if you look for:

http://korma.wmflabs.org/browser/people.html?id=4443&name=aklapper

the data is available.

Our current architecture pregenartes data in JSON format.

Thank you!

Sorry, reopening.

I guess Helder arrived to that link after clicking the corresponding username in some list? Can you please explain how you got there, please?

If a contributor shows up in some list it means that we do have some data about that user that could be shown there, isn't it? That data should be displayed in the related page.

In the worst case a text should say "Sorry, currently we don't have data available about this contributor."

In its current state it does indeed feel as something went wrong.

I have closed this issues because the problem is not with jQuery, but that we don't have data for all people, but only for tops.

But you are right Quim that we need to stay clearly that the case is that we don't have data for this user.

But maybe we can open another issue and close this one.

What do you think?

(In reply to comment #2)

I guess Helder arrived to that link after clicking the corresponding username
in some list? Can you please explain how you got there, please?

I clicked in the link "bugzilla.wikimedia" (section "Top Openers"):
http://korma.wmflabs.org/browser/

Let's evolve this report, since we already have it. I just edited the subject to reflect the case of an empty user page without data.

Still, if a contributor is in a list, this means that we do have some data about that contributor. The problem then might be that we are not showing all data available in contributor pages.

Yes, right now we are not generating data for all people.

The current vizgrimoire architecture is based in pre-generating all needed data for the browser in JSON files. Right now only the top contributors data is generated (people in lists).

So if a person is in a list, the data should be available. The "Top Openers" has being added recently and the data for them is not generated yet. This is a bug.

In the midterm we plan to generate data for all people.

Quim you are correct: if we don't have the data, just say that.

So to fix this issue:

  • Check all top openers data is generated
  • If someone is trying to access a people page without data about this person, say it in the UI.

I will add this work to our workplan.

According to Alvaro, currently every single username link visible in Korma must lead to a username page with information.

I have done some tests here and there and this seems to be true. Closing as WORKSFORME (now). Please reopen if you still find a link leading to an empty page.

Today at the weekly deployments meeting, we wanted to know more about a contributor called Frédéric Wang, I went to http://korma.wmflabs.org/browser/contributors.html , found him, but got an empty page:

http://korma.wmflabs.org/browser/people.html?id=1038&name=Fr%C3%A9d%C3%A9ric%20Wang

Qgil lowered the priority of this task from Medium to Low.Jan 8 2015, 11:25 AM

Note that the 404 errors part is T65061; this task is about displaying an empty page.

In T58111#628664, @Acs wrote:

Yes, right now we are not generating data for all people.

The current vizgrimoire architecture is based in pre-generating all needed data for the browser in JSON files. Right now only the top contributors data is generated (people in lists).

So if a person is in a list, the data should be available.

I am not sure if T117871: Many profiles on profile.html do not display identity's name though data is available is a duplicate. Probably not because this T58111 is about showing the contributor name but apart from that an empty page.

  • Check all top openers data is generated
  • If someone is trying to access a people page without data about this person, say it in the UI.

I will add this work to our workplan.

Has the situation changed in the meantime?

Aklapper renamed this task from Contributor pages without data should include an explanation to Contributor pages which show user name but not any other data should include an explanation.Nov 7 2015, 10:58 PM
Aklapper set Security to None.
Aklapper removed a subscriber: wikibugs-l-list.

This weird issue is related to the fact that not all of the developers are listed, but the most important ones in terms of activity per data source.

A potential way of dealing with this is to add all of the developers to the lists or to remove the developer link page.

These might come from before using SortingHat.

@Dicortazar said maybe "IRC source"-only accounts could use "the old way". (We have 80000 UUIDs so this would not scale.)

(Only potentially related: T112528)

These might come from before using SortingHat.
@Dicortazar said maybe "IRC source"-only accounts could use "the old way". (We have 80000 UUIDs so this would not scale.)

(After parsing our JSON file half of the accounts are actually MediaWiki accounts, not IRC accounts.)

I've included some changes on the people.html panel.

When a panel is displayed with no data it displays the message "Sorry, currently we don't have data available about this contributor". You can test it with any of the links provided in previous comments.

Due to the error seen in IRC, where users panels have charts and not profile information (this data is obtained from people.json where unique identities are matched), I've disbled the charts when a profile is not created there.

Changes on the library:
https://github.com/VizGrimoire/VizGrimoireJS-lib/commit/77c9fdce611dfce4ac439f807112d03a60736c7e

Changes on the people.html panel:
https://github.com/Bitergia/mediawiki-dashboard/commit/64bba5108f626a195953e64a94c87d24710017d2