Page MenuHomePhabricator

VisualEditor: Appending to a line shows additions before end of line in diff
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Find a page that already has a category
  2. Edit in VE, and add a category
  3. Review changes

Expected results:
The diff is

+**[[Category:New cat]]**

Actual results:
The diff is

-[[Category:Old cat]]
+[[Category:Old cat**]][[Category:New cat**]]

With the chunk between the stars viewed as added.

This also happens in the source editor, but it is less common that people will append a category to an existing category as that is against all style guidelines. However the Visual Editor is doing just that.


Version: 1.23.0
Severity: normal

Details

Reference
bz56880

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 2:27 AM
bzimport set Reference to bz56880.
bzimport added a subscriber: Unknown Object (MLST).
jayvdb created this task.Nov 11 2013, 5:03 AM
Aklapper updated the task description. (Show Details)Sun, Aug 11, 9:45 PM
Aklapper removed a subscriber: wikibugs-l-list.
Aklapper closed this task as Resolved.Sun, Aug 11, 9:47 PM
Aklapper lowered the priority of this task from Normal to Low.
Aklapper edited projects, added VisualEditor; removed MediaWiki-History-and-Diffs.
Aklapper added a subscriber: Aklapper.

I cannot reproduce this anymore with VE visual mode; the category gets added in a separate new line. Maybe this got fixed in T135667.
Please reopen if you can still reproduce.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSun, Aug 11, 9:47 PM