Some navbox and other templates disappear when being moved, but only if <ref> tags are present in the article and the templates are below the last visible text
Closed, ResolvedPublic

Description

Intention:
Change the location of a navigation template in an article

Steps to Reproduce:

  1. Click once on a "navbox" type template at the bottom of a page to select it.
  1. Click and drag the item to any place in the article.

Actual Results:
In affected articles, the navbox disappears upon dropping. Affected articles include:

https://en.wikipedia.org/wiki/Yersinia_pseudotuberculosis

https://en.wikipedia.org/wiki/Albert_I_of_Belgium

https://en.wikipedia.org/wiki/Vancouver_Canucks

Unaffected articles include:

https://en.wikipedia.org/wiki/Dunn_Peak_massif

https://en.wikipedia.org/wiki/Waging_Heavy_Peace:_A_Hippie_Dream

https://en.wikipedia.org/wiki/British_Columbia

If all the <ref> tags are removed from these articles, then dragging and dropping works as expected. Removing only some refs (even leaving in just one plain text ref) is not sufficient, except that transcluded notes/refs (in the Canucks article) are okay.

Expected Results:
That it would drag and drop normally in all articles.

Reproducible: Sometimes

This has been confirmed by at least three users, so it's probably platform independent.

Changing from {{reflist}} to <References /> has no effect. Removing all templates has no effect. Other non-floated templates (i.e., {{InterPro content}}) do not seem to be affected.

If you:

  1. Remove all the refs,
  2. Move the navbox template, and
  3. Then add a new ref,

(in that exact order), you can still move the navbox without it disappearing, despite the presence of your new ref.


Version: unspecified
Severity: normal

bzimport added a project: VisualEditor.Via ConduitNov 22 2014, 2:30 AM
bzimport set Reference to bz56923.
Whatamidoing-WMF created this task.Via LegacyNov 12 2013, 1:29 AM
Whatamidoing-WMF added a comment.Via ConduitNov 12 2013, 1:32 AM

This is reproducible every time in affected articles, and never in unaffected ones. I have no idea why some articles are affected and others are not.

Whatamidoing-WMF added a comment.Via ConduitNov 18 2013, 7:19 PM

This problem also exists with some other types of non-floating templates:

Whatamidoing-WMF added a comment.Via ConduitNov 20 2013, 7:41 PM

The problem may be due to the location of the templates rather than their identity. http://en.wikipedia.org/wiki/Gennady_Golovkin contains two succession boxes, but only the one at the end of the page disappears when it is moved.

Jdforrester-WMF changed the task status from "Open" to "Stalled".Via WebFeb 2 2015, 7:24 PM
neilpquinn added a subscriber: neilpquinn.Via WebFeb 3 2015, 10:20 PM

I checked all the affected articles listed by @Whatamidoing-WMF, and the templates in question can now be properly dragged.

Jdforrester-WMF closed this task as "Resolved".Via WebFeb 3 2015, 11:01 PM
Jdforrester-WMF claimed this task.

OK, in that case now marking as resolved.

Add Comment