Page MenuHomePhabricator

Allow links in Flow topic titles
Closed, ResolvedPublic

Description

When a topic title includes an internal link, the title should render as a working link in the topic header.

This will use the edit summary parser.

Examples:
The topic title is [[Foo]] -- it will render as Foo -- a link to the article page Foo.
The topic title is [[Foo|Bar]] -- it will render as Bar -- a link to the article page Foo.
The topic title is [http://foo.com Foo] -- it will render as Foo -- an external link to foo.com. (We decided to use the edit summary parser, which does not support this.)

NOTE #1: For posts, replies and edits to a post/reply -- in watchlist, recent changes and contributions, there will be a blue link that says Foo -- but this will NOT be a link to the article page Foo. It will be a link to the Topic:UUID. See screenshots below.

NOTE #2: In topic history, board history, watchlist, recent changes and contributions, when there is a change to the topic summary, or moderation actions, the topic title will be rendered as Foo, no link.
For example: created topic summary on Foo

Topic heading -- this should be a working link

Contributions --
For the post/reply/edit, the link should render as the title (no brackets), and should link to the Topic:UUID, not to the page.
For editing the topic summary, the link should render as the title, not linked.

Recent changes --
For the post/reply/edit, the link should render as the title (no brackets), and should link to the Topic:UUID, not to the page.
For editing the topic summary, the link should render as the title, not linked.

Watchlist --
For the post/reply/edit, the link should render as the title (no brackets), and should link to the Topic:UUID, not to the page.
For editing the topic summary, the link should render as the title, not linked.

Board and Topic history --
For both post/reply/edit and editing the topic summary, the link should render as the title, not linked.

See T115910: Track references in topic titles.


previous version of the ticket:

Flow: Wikitext formatting (such as [[links]] and ''italics'') doesn't work in topic titles

When you create a new Flow thread, there's a "topic" field. This topic field is analogous to the "subject" field in a wikitext talk page. The topic field currently cannot support wikitext.

Example: http://ee-flow.wmflabs.org/w/index.php?title=Sandbox&workflow=0509a3b2518b34dffb6efa163e68c4ac&action=view

Topic input: "here's a new [[topic]]"

Expected behavior: "[[topic]]" becomes an internal hyperlink


Version: unspecified
Severity: enhancement
URL: http://ee-flow.wmflabs.org/w/index.php?title=Sandbox&workflow=0509a3b2518b34dffb6efa163e68c4ac&action=view
See Also:

https://trello.com/c/bj3IZSE5/190-limited-wikitext-formatting-in-topic-titles

Details

Reference
bz57153
Related Gerrit Patches:

Related Objects

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
He7d3r updated the task description. (Show Details)Jun 10 2015, 1:00 PM
He7d3r added a project: Regression.
Qgil added a subscriber: Qgil.Jun 11 2015, 10:39 AM
Sunpriat updated the task description. (Show Details)Jun 17 2015, 3:43 PM

@DannyH https://trello.com/c/bj3IZSE5/190-limited-wikitext-formatting-in-topic-titles

We shouldn't do wikitext in topic titles -- titles will be used in log pages like contributions, watchlist, etc.

Many wikis use titles with wikitext "==[[PageInTitle]]==" and special log pages showing simply "PageInTitle" and links [[ SomePage#PageInTitle ]] work fine. Why this can not further work so?

Elitre added a subscriber: Elitre.Jun 30 2015, 3:08 PM

We discussed the possibility of using the same subset the edit summary parser allows.

In T59153#1439920, @Mattflaschen wrote:

We discussed the possibility of using the same subset the edit summary parser allows.

That would be the least. You've already broken many topic titles:
https://www.mediawiki.org/wiki/Talk:MediaWiki_Stakeholders%27_Group

DannyH renamed this task from Flow: Wikitext formatting (such as [[links]] and ''italics'') doesn't work in topic titles to Allow links in Flow topic titles.Jul 24 2015, 8:07 PM
DannyH raised the priority of this task from Lowest to Normal.
DannyH updated the task description. (Show Details)
Ricordisamoa awarded a token.
DannyH raised the priority of this task from Normal to High.Aug 20 2015, 8:35 PM

Change 243066 had a related patch set uploaded (by Mattflaschen):
WIP: Add support for edit summary formatting in topic titles

https://gerrit.wikimedia.org/r/243066

DannyH removed a subscriber: DannyH.Oct 5 2015, 10:46 PM
revi awarded a token.Oct 9 2015, 6:54 PM
revi added a subscriber: revi.
Mattflaschen-WMF updated the task description. (Show Details)

Change 243066 merged by jenkins-bot:
Add support for edit summary formatting in topic titles

https://gerrit.wikimedia.org/r/243066

Checked in betalabs according to specs. Please check below
Talk:ET19 - the link in the title and in the Summary - [[Talk:ET1|ET1]]

Topic heading -- this should be a working link

  1. The links to the topic ET1 are rendered as for the Recent changes - see below

Contributions -
For the post/reply/edit, the link should render as the title (no brackets), and should link to the Topic:UUID, not to the page.
For editing the topic summary, the link should render as the title, not linked.

Recent changes --
For the post/reply/edit, the link should render as the title (no brackets), and should link to the Topic:UUID, not to the page.
For editing the topic summary, the link should render as the title, not linked.

Watchlist --
For the post/reply/edit, the link should render as the title (no brackets), and should link to the Topic:UUID, not to the page.
For editing the topic summary, the link should render as the title, not linked.

  1. Links are in the right place - checked.

Board and Topic history --
For both post/reply/edit and editing the topic summary, the link should render as the title, not linked.

Etonkovidova added a comment.EditedNov 20 2015, 11:27 PM

Filed as a separate issue T119537: Links in Flow topic titles: html code displayed when page scrolls up

  • Have a title with a link in it
  • scroll up - the link exposes html code:

Johan added a subscriber: Johan.Nov 25 2015, 11:33 AM

(This will be announced in Tech News the week after next, as there's no MediaWiki deployment next week.)

Catrope closed this task as Resolved.Dec 4 2015, 1:06 AM
Catrope added a subscriber: Catrope.

Watchlist --
For the post/reply/edit, the link should render as the title (no brackets), and should link to the Topic:UUID, not to the page.
For editing the topic summary, the link should render as the title, not linked.

That looks like a bug: those brackets should not appear. I've filed T120329: Brackets appear in history when topic title that contains link is changed for this, so we can close this bug.