Page MenuHomePhabricator

install QT sdk
Closed, DeclinedPublic

Description

there are no QT libraries so it's not possible to run C++ app's that use QT libraries.

Please install full QT on all nodes, so that all modules are present. Preferably both QT 4 and 5


Version: unspecified
Severity: enhancement

Details

Reference
bz57241

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 2:23 AM
bzimport added a project: Toolforge.
bzimport set Reference to bz57241.
Petrb created this task.Nov 19 2013, 12:58 PM
coren added a comment.Nov 20 2013, 2:52 PM

There are a number of fundamental problems with that request:

  1. QT5 is only supported starting with Raring.
  2. QT pulls in X11 libraries as a dependency
  3. The submitted patch includes a lot of things that aren't actually needed.

X11 isn't apropriate for deployment on compute nodes. Please rebuild the tool that needs it against non-X11 libraries, or correct the list of dependencies to only include actual dependencies if there that is already the case.

Change 96478 abandoned by Hashar:
Inserted QT libraries

Reason:
Apparently no more needed

https://gerrit.wikimedia.org/r/96478