VisualEditor: Pawning and reversed typing in Firefox
Closed, ResolvedPublic

Description

Author: Wikifram

Description:
There are a number of bugs about pawns and/or reverse typing, many of them "resolved fixed". But it is clear that in many circumstances, on different wikiversions, pawn characters and reverse typing still occur.

See [[en:Wikipedia:VisualEditor/Feedback#Line with template, pawn]] (and the linked sections on fr-wiki as well) for an explanation of some scenarios when this occurs. This has, in various guises, been reported since the first deployment of VE, and none of the fixes seem to have been permanent or fundamental. Can this please be tackled?


Version: unspecified
Severity: major

bzimport set Reference to bz57347.
bzimport created this task.Via LegacyNov 21 2013, 10:35 AM
Elitre added a comment.Via ConduitNov 21 2013, 3:06 PM

In short (and partially reusing Fram's words).
This happens in FF, in both MB and Vector.

  1. VEdit https://en.wikipedia.org/wiki/Selan_(Dungeons_%26_Dragons) .
  2. Put your cursor at the start of the text (i.e. before "In the...").
  3. Arrow left.
  4. Arrow left.
  5. Start typing.

A pawn appears.

Also:

  1. and 2. as above.
  2. Arrow left.
  3. Arrow right (nothing happens; a bug in its own right?)
  4. Arrow right.
  5. Start typing.

You are typing backwards.

Elitre added a comment.Via ConduitNov 21 2013, 3:15 PM

The above was related to templates (that is, a weird behavior when templates are selected and then deselected via keyboard arrows). The opposite happens when dealing with references.

  1. https://en.wikipedia.org/wiki/Selan_%28Dungeons_%26_Dragons%29?veaction=edit
  2. Put your cursor right after the first reference number ([1]).
  3. Arrow left.
  4. Arrow left.
  5. Start typing.

You are typing backwards.

Also:

  1. and 2. as above.
  2. Arrow left.
  3. Arrow right.
  4. Start typing.

A pawn appears.

Jdforrester-WMF added a comment.Via ConduitNov 26 2013, 1:21 PM

Merging into bug 54917 which is the same, yes.

  • This bug has been marked as a duplicate of bug 54917 ***
Jdforrester-WMF added a comment.Via ConduitNov 26 2013, 4:50 PM

Re-merged with bug 57600, as slightly distinct from bug 54917.

  • This bug has been marked as a duplicate of bug 57600 ***

Add Comment