The "page reviewed" and the "page patrolled" functions should be split into 2 separate types, so that proper links can be assigned.
If that's too complicated (or rapidly in the meantime) the description sent to the Notification-recipient should be changed from:
"was reviewed by"
"was patrolled or reviewed by"
with the word "patrolled" linked to [[Wikipedia:New pages patrol/patrolled pages]]