Page MenuHomePhabricator

"/" string suffix shown at the end in a style="text-align:left" section on RTL wiki
Closed, InvalidPublic

Description

Author: omid_h28

Description:
Slash Chracter in RTL WIki

suppose I want to write "/hello" Left-to-Right in a RTL wiki:

<div style="text-align:left">/hello </div>

but the result is this:

hello/

Slash character doesn't show properly.


Version: 1.23.0
Severity: normal
OS: Linux
Platform: PC

Attached:

Details

Reference
bz57789

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 2:33 AM
bzimport set Reference to bz57789.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Dec 1 2013, 6:39 AM
TheDJ added a comment.Dec 2 2013, 11:36 AM

but shouldn't it be <div style="text-align:left;" dir="ltr">/hello </div>

in that case ? How would bidi now it's an ltr text otherwise ?\x10

I think this is an invalid report. I think that directionality hints and browser specific implementations of the bi-directional text algorithms depend how this is rendered.

Will ask Amir to assess.

(In reply to comment #2)

but shouldn't it be <div style="text-align:left;" dir="ltr">/hello </div>
in that case ? How would bidi now it's an ltr text otherwise ?\x10

If I understand the report correctly the right thing to do is to use
<div lang="en" dir="ltr" class="mw-content-ltr">/hello</div>

style="text-align:left" is not supposed to be needed if you use the above attributes.

Please reopen if Derk-Jan and I misunderstand something.

omid_h28 wrote:

(In reply to comment #4)

(In reply to comment #2)

but shouldn't it be <div style="text-align:left;" dir="ltr">/hello </div>
in that case ? How would bidi now it's an ltr text otherwise ?\x10

If I understand the report correctly the right thing to do is to use
<div lang="en" dir="ltr" class="mw-content-ltr">/hello</div>
style="text-align:left" is not supposed to be needed if you use the above
attributes.
Please reopen if Derk-Jan and I misunderstand something.

It worked, Thanks

There was no valid bug in existing MediaWiki code here, hence nothing was FIXED either. Resetting to INVALID.

Mid-air collision with explanation:

Updating the resolution back to the original "invalid". Per https://www.mediawiki.org/wiki/Bug_management/Bug_report_life_cycle :

  • RESOLVED INVALID when the problem is not a bug.
  • RESOLVED FIXED when a code change that fixes the reported problem has been merged in Gerrit.
Restricted Application added a project: I18n. · View Herald TranscriptJun 2 2015, 2:20 PM