Special:Book is unable to export in ODT format on all wikis
Closed, ResolvedPublic

Description

Author: robin.herve

Description:
Whereas this works well on Wikipedia (at least "frwiki"), mediawiki.org seems
to be unable to export in the ODT format. If you choose "ODT", the
"Special:Book" page will generate a PDF instead.

To reproduce:
1 - Enable book creator
2 - Add any page
3 - Generate the book, choose "ODT"
4 - Download the file

The file is a PDF, it should be an OpenDocument version of the book.


Version: wmf-deployment
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=57920
https://bugzilla.wikimedia.org/show_bug.cgi?id=58151

Details

Reference
bz57975
bzimport raised the priority of this task from to High.
bzimport set Reference to bz57975.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Dec 4 2013, 12:42 PM
Kelson added a comment.Dec 7 2013, 4:32 PM

This seems to impact all wikis, I have tested this with nlwiki and frwiki too.

ekrem.koc wrote:

I have same problem here. )-:

I use Mozilla Firefox 25.0.1

marcin.iwinski wrote:

Same problem exporting to epub. Happened to me on wikipedia.org and wikivoyage.org. I've also reported a bug for that - https://bugzilla.wikimedia.org/show_bug.cgi?id=58151

Bug 57975, bug 57920 and bug 58151 are currently investigated by mwalker.

mwalker wrote:

*** This bug has been marked as a duplicate of bug 58151 ***

mwalker wrote:

Actually; I'll not mark as duplicate -- it looks to be the same thing; but maybe not.

ekrem.koc wrote:

.ODT works normal now. change: FIX?

ekrem.koc wrote:

Sorry I did open .ODT in LibreOffice 4.1.3.2 and this said:
In reading problem.
Error reading file.

Same problem by you too?

Ekrem: Such comments are way more helpful if you provide exact and specific steps to reproduce. Plus this bug is NOT about invalid ODT files but about creating PDF files instead of ODT files instead.

mwalker wrote:

I reverted the change(In reply to comment #7)

.ODT works normal now. change: FIX?

I reverted the patch that was causing the error -- but I'm not marking this as fixed yet because the patch is required for some other stuff I'm doing. Therefore I actually need to fix it rather than just revert :)

(In reply to comment #10 by mwalker)

Therefore I actually need to fix it rather than just revert :)

mwalker: Any news / progress?

mwalker wrote:

Just tested on mediawiki.org -- looks like it's working in wmf10; so marking resolved fixed.