Page MenuHomePhabricator

changes to ordering don't persist under certain condition
Closed, InvalidPublic

Description

When I change a statement and at the same time change its sort order then the sort order change is not saved. (Needs a page reload to see sort order going back to previous state.)


Version: master
Severity: major
Whiteboard: u=dev c=backend p=0

Details

Reference
bz58180

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 2:31 AM
bzimport set Reference to bz58180.
bzimport added a subscriber: Unknown Object (MLST).

After further investigation with Henning we found out that the issue is a bit different. The ordering change does not seem to get saved when moving down - only up. Editing at the same time doesn't seem to make a difference.

I can reproduce this locally. Very strange. I will take and try to fix this one since it's very confusing and can act as a blocker for certain users. I have the feeling this could be caused be a single line, possibly a single character misplaced or missing. The problem is, as usual, to find that character. ;-)

Please talk to Henning or Tobi about this quickly before spending time on it. I'm not sure if there is a fundamental issue that can't easily be fixed.

  • Bug 63559 has been marked as a duplicate of this bug. ***
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).Dec 1 2014, 2:31 PM
adrianheine closed this task as Invalid.Mar 10 2015, 8:49 AM
adrianheine claimed this task.

Moving is not supported anymore.