Page MenuHomePhabricator

File revert counts as 'overwrite', not 'revert'
Closed, ResolvedPublic

Description

When someone revert file to older version, in edit history it appears as a new upload, not classic MediaWiki-style file revert.
Example: https://commons.wikimedia.org/w/index.php?title=File:Internet_Explorer_9_icon.svg&action=history

Details

Reference
bz58209

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 2:33 AM
bzimport set Reference to bz58209.
bzimport added a subscriber: Unknown Object (MLST).

I guess you want a notification to come up when a file is reverted?

https://www.mediawiki.org/wiki/Help:Notifications

(In reply to comment #2)

I guess you want a notification to come up when a file is reverted?
https://www.mediawiki.org/wiki/Help:Notifications

First of all, but this action just should follow with MediaWiki-revert method:
''Undid revision 123456789 by User (talk)''
not
''User uploaded a new version of File:xxx''

You see, it shouldn't appear as new upload, but a revert.

  • Bug 30197 has been marked as a duplicate of this bug. ***

Merging comment 1 from bug 30197 (Unused Log upload/revert):
As current type is upload/overwrite used for file reverts. But $wgLogActions
has an entry for that, that should used when reverting a file, that is right.

Restricted Application added subscribers: Luke081515, Aklapper. · View Herald TranscriptApr 2 2016, 7:22 PM
MGChecker updated the task description. (Show Details)
MGChecker removed a subscriber: wikibugs-l-list.
Restricted Application added projects: Commons, Multimedia. · View Herald TranscriptOct 1 2018, 4:20 PM

Change 463819 had a related patch set uploaded (by MGChecker; owner: MGChecker):
[mediawiki/core@master] Add separate log action for file reverts

https://gerrit.wikimedia.org/r/463819

@aaron, @Bawolff, @Umherirrender As you are listed as maintainers for Multimedia and Logging, I would love this to be reviewed by you.

Change 463819 merged by jenkins-bot:
[mediawiki/core@master] Add separate log action for file reverts

https://gerrit.wikimedia.org/r/463819

MGChecker closed this task as Resolved.Mar 3 2019, 12:55 PM