Page MenuHomePhabricator

Echo: User should not see a notification with raw wikitext " [[User:[Nobody]|[Nobody]]]" in it.
Closed, ResolvedPublic

Description

Screenshot of problem.

On mediawiki.org I just got the following notification:

__

[[User:[Nobody]|[Nobody]]] thanked you for your edit
on MediaWiki talk:Gadget-UTCLiveClock.js.
1 day agoView edit
__

Edit in question:

https://www.mediawiki.org/w/index.php?title=MediaWiki_talk:Gadget-UTCLiveClock.js&oldid=prev&diff=835266

Log:

https://www.mediawiki.org/wiki/Special:Log/thanks?page=User:Krinkle

Whatever the case, the main issue is that [Nobody] doesn't parse when used inside [[User:]] in wikitext (at least not in the parser Echo uses for this). So either it should be replaced with a placeholder, or perhaps the notification should be hidden entirely if it doesn't have sufficient data.

Either way, it should not be communicating a transaction with user=[Nobody] because that is an invalid username and also invalid page title for user pages in general. Presumably the latter is on purpose, (so that it can't point to an existing user, though we do have reserved usernames for certain purposes), but then it shouldn't try to parse it as such inside the notification.


Version: unspecified
Severity: major
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=50829

Attached:

Details

Reference
bz58234

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 2:35 AM
bzimport added a project: Notifications.
bzimport set Reference to bz58234.
bzimport added a subscriber: Unknown Object (MLST).
Krinkle created this task.Dec 9 2013, 8:07 PM

The Thanks bug which caused the broken notification has been fixed and is just awaiting deployment.

The use of "[nobody]" when there is no user or the username has been suppressed is bad and should be fixed.

Which commit is that?

  • Bug 69128 has been marked as a duplicate of this bug. ***
Legoktm moved this task from Backlog to Needs code on the Notifications board.Jul 6 2015, 8:43 AM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJul 6 2015, 8:43 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 3 2015, 11:27 PM
Catrope closed this task as Resolved.Apr 18 2016, 9:25 PM
Catrope claimed this task.
Catrope added a subscriber: Catrope.

This was fixed by the notification formatter rewrite in October.