Page MenuHomePhabricator

Diff line numbers incorrect. Possibly due to prior diff
Closed, ResolvedPublic

Description

Author: nathanwcaldwell

Description:
I've been trying to calculate a new article based on an original article and diffs.

http://en.wikipedia.org/w/index.php?title=Florida&diff=582177432&oldid=581998623 That is the diff table for certain revisions for the Florida Wikipedia page.

http://en.wikipedia.org/w/index.php?title=Florida&action=edit&oldid=581998623 That is the page source being used for the base article being diffed to.

http://en.wikipedia.org/w/index.php?title=Florida&action=edit&oldid=582177432 That is the page source of the next revision that the article is being diffed

If you open up these two sources in a text editor you can see the line count. Now, look at the diff table (first thing I linked). Look at the entry for the diff for original article line 359 and new article line 361. The lines before the change should line up, right? If I had to guess what's causing it, I would say it's the diffs above it. Part of a line is being removed, but not otherwise changed, and this removed text is then being added as a new paragraph.


Version: 1.23.0
Severity: normal

Details

Reference
bz58268

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 2:38 AM
bzimport set Reference to bz58268.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Dec 10 2013, 1:29 PM

The lines before the change should line up, right?

I'm not sure if I understand what you mean. Please elaborate.

nathanwcaldwell wrote:

Let me rewrite that whole paragraph.

If you open up these two sources in a text editor you can see the line count. Now, look at the diff table (first thing I linked). The diff for the original article is correct and begins at line 359. However, the diff for the second article begins at line 365 in my text editor whereas the diff table says it should begin at line 361. If I had to guess what's causing it, I would say it's the diffs above it. Part of a line is being removed, but not otherwise changed, and this removed text is then being added as a new paragraph.

Aklapper closed this task as Resolved.Sun, Aug 11, 9:55 PM
Aklapper edited subscribers, added: Aklapper; removed: wikibugs-l-list.

However, the diff for the second article begins at line 365 in my text editor whereas the diff table says it should begin at line 361

Cannot reproduce anymore, hence closing as resolved: