Page MenuHomePhabricator

VisualEditor: undefined error during copy
Closed, ResolvedPublic

Description

I selected all VE content from: "It is important to make", up to "Mediawiki-l mailinglist thread "mysql5 binary schema" 25.03.2009"

I could pinpoint it to trying to copying the Header "scripts" and the warning template that follows it.

[Error] TypeError: 'undefined' is not an object (evaluating 'delete children[i].values[attribute]')
removeAttributeRecursive (load.php, line 20)
removeAttributeRecursive (load.php, line 20)
removeHtmlAttribute (load.php, line 20)
getClonedElement (load.php, line 202)
cloneElements (load.php, line 170)
onCopy (load.php, line 292)
proxy (load.php, line 10)
dispatch (load.php, line 45)
eventHandle (load.php, line 38)


Version: unspecified
Severity: normal
URL: https://www.mediawiki.org/wiki/Manual:Backing_up_a_wiki?veaction=edit

Details

Reference
bz58379

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 2:15 AM
bzimport set Reference to bz58379.
TheDJ created this task.Dec 12 2013, 9:24 AM
TheDJ added a comment.Dec 12 2013, 9:32 AM

On Safari 7 btw:

I have a slight suspicion thrown Undefined errors like these during copy might also be responsible for the broken internal links that are pasted: Manual:Restoring a wiki from backup

Jdforrester-WMF closed this task as Resolved.Apr 8 2015, 9:01 PM
Jdforrester-WMF claimed this task.

Can't reproduce any more. We did a lot of changes to Select-All in the intervening period, which probably fixed it.