Page MenuHomePhabricator

"Show"/"Hide" toggle links in various special pages should be localizable per item
Open, NormalPublic

Description

The "Show"/"Hide" links in various special pages options box should be localizable per item.

Identified special pages:

  • Special:RecentChanges
  • Special:Watchlist
  • Special:Log
  • Special:NewPages
  • Special:WhatLinksHere

Note that Special:NewFiles uses this approach.

Currently, every one of them is produced using the same message ('hide' or 'show'), which makes it impossible to translate them correctly in languages which would require them to be conjugated or something.

Apparently this is a problem on ce.wikipedia, it was reported to me by one of the users there.

https://pl.wikipedia.org/w/?oldid=38131995#Recent_changes
https://ce.wikipedia.org/w/?oldid=150532#re:_pl:Dyskusja_wikipedysty:Matma_Rex.23Recent_changes
https://translatewiki.net/wiki/Thread:Support/About_MediaWiki:Log-show-hide-thanks/ksh


Version: 1.23.0
Severity: normal
See also: T20577: replace "show/hide" by an icon
Attached:

Details

Reference
bz58449

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 2:20 AM
bzimport set Reference to bz58449.
bzimport added a subscriber: Unknown Object (MLST).
matmarex created this task.Dec 13 2013, 2:50 PM

Created attachment 14085
How it should apparently be translated in Chechen (ce)

(Courtesy of [[:ce:User:Дагиров Умар]]).

Attached:

MatmaRex: Thanks for describing the issue, because I failed to understand it. :(

https://git.wikimedia.org/raw/mediawiki%2Fcore.git/HEAD/languages%2Fmessages%2FMessagesCe.php :
'rcshowhideminor' => '$1 кегийра нисдарш',
'rcshowhidebots' => '$1 шабелхалой',
'rcshowhideliu' => '$1 шайн цӀершца болу декъашхой',
'rcshowhideanons' => '$1 цӀе хьулйина декъашхой',
'rcshowhidepatr' => '$1 хьажжина нисдарш',
'rcshowhidemine' => '$1 айхьа нисдинарш',
'hide' => 'Къайлаяккха',

Change 109296 had a related patch set uploaded by Microchip08:
Make show/hide link in RC individually localizable

https://gerrit.wikimedia.org/r/109296

Umar added a comment.Feb 3 2014, 12:32 PM

Hi. What to do next? Sorry if that.

Change 109296 merged by jenkins-bot:
Make show/hide link in RC individually localizable

https://gerrit.wikimedia.org/r/109296

Done now! The new messages should be added on Translatewiki soon. Have fun translating :)

Pikne added a comment.Feb 27 2014, 6:07 PM

Hm, I'm probably late with my comment, but in Estonian we need to decline the noun differently depending on whether it is preceded by "hide" or "show". So more favourable solution would have been to include the noun also in these new per item messages.

Additional comments here:
[[:translatewiki:Thread:Translating talk:MediaWiki/Split some show/hide messages?]]

Umar added a comment.Feb 27 2014, 7:40 PM

Sorry but where to translate the word to hide this message? Should be Къайлабаха

https://translatewiki.net/w/i.php?title=MediaWiki:Wikibase-rc-hide-wikidata/ce&action=edit

Change 116137 had a related patch set uploaded by Bartosz Dziewoński:
SpecialRecentchanges: Don't use nonexistent messages for filter selector

https://gerrit.wikimedia.org/r/116137

Change 116054 had a related patch set uploaded by Bartosz Dziewoński:
Add flaggedrevs-hidereviewed show / hide i18n messages

https://gerrit.wikimedia.org/r/116054

Change 116096 had a related patch set uploaded by Bartosz Dziewoński:
Add missing recent changes show/hide messages

https://gerrit.wikimedia.org/r/116096

This caused some troubles with extensions, see bug 62050. Patches above are to fix them.

(In reply to Umar from comment #9)

Sorry but where to translate the word to hide this message? Should be
Къайлабаха
https://translatewiki.net/w/i.php?title=MediaWiki:Wikibase-rc-hide-wikidata/
ce&action=edit

Yeah, we forgot about this. One of the new patches above is for this, you will be able to translate the text at https://translatewiki.net/w/i.php?title=MediaWiki:Wikibase-rc-hide-wikidata-hide/ce&action=edit

(In reply to Pikne from comment #7)

Hm, I'm probably late with my comment, but in Estonian we need to decline
the noun differently depending on whether it is preceded by "hide" or
"show". So more favourable solution would have been to include the noun also
in these new per item messages.
Additional comments here:
[[:translatewiki:Thread:Translating talk:MediaWiki/Split some show/hide
messages?]]

Please file a separate bug for this :)

(In reply to Bartosz Dziewoński from comment #13)

(In reply to Pikne from comment #7)

Hm, I'm probably late with my comment, but in Estonian we need to decline
the noun differently depending on whether it is preceded by "hide" or
"show". So more favourable solution would have been to include the noun also
in these new per item messages.

Please file a separate bug for this :)

I filed bug 62067 and CC'd you.

Change 116054 merged by jenkins-bot:
Add flaggedrevs-hidereviewed show / hide i18n messages

https://gerrit.wikimedia.org/r/116054

Change 116096 merged by jenkins-bot:
Add missing recent changes show/hide messages

https://gerrit.wikimedia.org/r/116096

Change 116215 had a related patch set uploaded by Hoo man:
SpecialRecentchanges: Don't use nonexistent messages for filter selector

https://gerrit.wikimedia.org/r/116215

Change 116137 merged by jenkins-bot:
SpecialRecentchanges: Don't use nonexistent messages for filter selector

https://gerrit.wikimedia.org/r/116137

Change 116215 merged by jenkins-bot:
SpecialRecentchanges: Don't use nonexistent messages for filter selector

https://gerrit.wikimedia.org/r/116215

Umar added a comment.Mar 5 2014, 10:34 PM

In Wikipedia nothing has changed even though it was recently updated

https://ce.wikipedia.org/wiki/%D0%91%D0%B5%D0%BB%D1%85%D0%B0%D0%BD:%D0%9A%D0%B5%D1%80%D0%BB%D0%B0_%D0%BD%D0%B8%D1%81%D0%B4%D0%B0%D1%80%D1%88

And on the site are all correct
https://translatewiki.net/w/i.php?title=Special:RecentChanges&translations=filter

This error or need to wait? Sorry if I'm disturbing you

For future, please state what you observe and what you expect to see.

Since this change includes a code change, it will take a week from now to appear.

Comment 21 said:
Since this change includes a code change, it will take a week from now to appear.

Hence no need to add further comments to this bug report in the next seven days.

Umar added a comment.Mar 28 2014, 3:04 PM

Sorry. You know what I mean?

I'm afraid I don't understand what the issue is :(

MC8 added a comment.Mar 28 2014, 9:11 PM

I think the issue is that [[Special:RecentChanges]] has the new translations, but the otherwise identical filters at [[Special:Contributions]] do not.

MC8 added a comment.Mar 28 2014, 9:24 PM

My apologies, when I previously stated [[Special:Contributions]], I meant to say [[Special:Watchlist]].

Umar added a comment.Apr 15 2014, 5:11 PM

Hi. I want to tell you about that in two special pages still nothing has changed.

See comment 28?

Umar added a comment.May 11 2014, 10:31 PM

Sorry. When can we expect a change?

Umar added a comment.Jun 20 2014, 6:53 PM

Hi. Somebody fix this error?

(In reply to Douglas Gardner from comment #28)

I think the issue is that [[Special:RecentChanges]] has the new
translations, but the otherwise identical filters at
[[Special:Watchlist]] do not.

Why is this bug RESOLVED FIXED then? reopening.

Umar added a comment.Jun 20 2014, 7:10 PM

If you do not understand what to do I will try to bring the question correctly.

Umar added a comment.Jun 20 2014, 7:12 PM

Status changed again for some reason Sorry

(In reply to Umar from comment #36)

If you do not understand what to do I will try to bring the question
correctly.

I think the issue here is clear: the change needs to be done for [[Special:Watchlist]] too. You only need to wait for some developer to take this bug and fix it. It may have passed unnoticed during some days because of the fact that it was marked as RESOLVED. Please, have a bit of patience :)

why not have a single message for filters of both recentchanges and watchlist?

  • Bug 62067 has been marked as a duplicate of this bug. ***
Umar added a comment.Oct 26 2014, 6:34 PM

I'm sorry but I'm waiting for a very long time, I know that nobody will pay but you took this job you please let me finish this work.

Sorry if I'm disturbing you.

Regards Administrator Chechen Wikipedia.

Amire80 claimed this task.Jan 6 2015, 12:08 PM
Umar added a subscriber: Umar.Feb 17 2015, 1:55 PM

Chechen Wikipedia nothing fixed!

Umar added a comment.Apr 8 2015, 6:36 PM

Why not fix it and close the query remains a little?

Umar added a comment.Apr 19 2015, 3:59 PM

Let's not wait another two years.

Nemo_bis renamed this task from "Show"/"Hide" links in recent changes / watchlist options box should be localizable per item to "Show"/"Hide" links in recent changes / watchlist / log options box should be localizable per item.May 14 2015, 7:31 AM
Nemo_bis updated the task description. (Show Details)
Nemo_bis set Security to None.
Umar added a comment.Oct 25 2015, 5:20 PM

Somebody deals with this problem?

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 25 2015, 5:20 PM

I think we should just get rid of those links and change them to checkboxes or some such. Having links for this type of controls is weird and not user friendly.

Using checkboxes would also allow to change several options at once without having to reload the page for each change, which is a plus

Umar added a comment.Oct 26 2015, 12:04 PM

This would solve the problem. Thank you

jrbs added a subscriber: jrbs.

For recent changes, this would be invalidated by T119084.

Umar added a comment.Jan 11 2016, 11:32 PM

Excuse me. However, your changes do not work here https://en.wikipedia.org/wiki/Special:NewPages

Ciencia_Al_Poder renamed this task from "Show"/"Hide" links in recent changes / watchlist / log options box should be localizable per item to "Show"/"Hide" links in recent changes / watchlist / log / newpages options box should be localizable per item.Jan 12 2016, 8:29 PM
Ciencia_Al_Poder updated the task description. (Show Details)
Ciencia_Al_Poder renamed this task from "Show"/"Hide" links in recent changes / watchlist / log / newpages options box should be localizable per item to "Show"/"Hide" toggle links in various special pages should be localizable per item.Jan 23 2016, 1:43 PM
Ciencia_Al_Poder updated the task description. (Show Details)
Ciencia_Al_Poder updated the task description. (Show Details)
Umar added a comment.May 10 2016, 5:21 PM

Prblemy not solved.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 10 2016, 5:21 PM

Prblemy not solved.

@Umar: We all know that, hence no need to tell us. Could you please refrain from adding such comments that do not add any helpful information to bug reports and just create notifications for everybody subscribed? Thank you. :)
If you would like to get this problem solved, please consider contributing patches or explain why this task should be more urgent than solving other tasks in the long list of unsolved tasks.

Umar added a comment.May 10 2016, 7:19 PM

Good. Thanks for the clarifications.

@Amire80: This issue has been assigned to you a while ago.
Could you please share a status update? Are you still working (or still plan to work) on this issue? Is there anything that others could help with? If you do not plan to work on this issue anymore, please remove yourself as assignee (via Add Action...Assign / Claim in the dropdown menu) so others could work on it. Thanks a lot!

Amire80 removed Amire80 as the assignee of this task.Oct 3 2017, 4:49 PM

is this bug still valid? (nowdays there are checkboxes in many places)

Pikne added a comment.May 24 2019, 6:07 AM

is this bug still valid? (nowdays there are checkboxes in many places)

It still affects the non-JavaScript version of Special:RecentChanges (available on an opt-in basis and as a fallback), also Special:NewPages and Special:WhatLinksHere are without checkboxes. For recent changes, as mentioned above, T119084 should be a viable solution.