Page MenuHomePhabricator

New jquery.placeholder.js is slow/placeholder text does not disappear in IE8
Closed, DeclinedPublic

Description

When log in to wikipedia the new jquery.placeholder.js (gerrit 98137) is used on Special:UserLogin. When the cpu is high, and the username is typed and than with tab the password field is selected and the password is typed, sometimes the first letters of the password are missing.
Sometimes the whole placeholder text is select and will stay in the input box.

Please revert or fix the new jquery.placeholder.js. Thanks.


Version: 1.23.0
Severity: major

Details

Reference
bz58536

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 2:25 AM
bzimport set Reference to bz58536.
bzimport added a subscriber: Unknown Object (MLST).

This was previously raised in the comments on that change by Umherirrender,
but I was unable to reproduce the issue quickly and did not have time to
poke at it more vigorously. :(

To quote:

Umherirrender, Nov 30 5:04 PM

qunit tests under IE8 fails for jquery.placeholder
jquery.placeholder: emulates placeholder for <input type=text> (3,
19, 22)

  • $el.val("") should change the value attribute
  • $el.val("") should re-enable placeholder class
  • $el.placeholder(<string>) should update the displayed placeholder value

jquery.placeholder: emulates placeholder for <input type=email> (3,
19, 22)

  • the same as above

jquery.placeholder: emulates placeholder for <input type=tel> (3,
19, 22)

  • the same as above

Expected is a value, but result is a empty string. Please have a
look. Thanks.

Bartosz Dziewoński, Nov 30 7:48 PM

All tests pass for me on IE8 :o http://i.imgur.com/TWGtJVO.png

Umherirrender, Nov 30 11:59 PM

Looks like a race condition, when cpu is high. Because sometimes it
fails with all tests and pass when testing the module only, but it
also possible that the module test failed. Seen with monobook and
vector.

Microsoft will drop support for Windows XP and therefor the user with Internet Explorer will decrease. Nobody will care about that in 3 months, marking wontfix. Other bugs also open to track the placeholder problems on some browser versions, see bug 48918 or bug 47057

If Microsoft drops support does not matter if in reality enough people still use it. Plus we are not actively against fixing this and would accept patches, hence reverting WONTFIX and setting low priority.

matmarex set Security to None.
matmarex removed a subscriber: Unknown Object (MLST).
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 21 2015, 4:40 PM
Umherirrender closed this task as Declined.Jan 7 2016, 6:53 PM
Umherirrender claimed this task.