Page MenuHomePhabricator

BetaFeatures: Validate skin requirement is installed before showing it
Closed, ResolvedPublic

Description

VisualEditor supports the 'apex' skin, however that isn't installed on WMF projects, so users using a non-supported skin will see "<skinname-apex>".


Version: unspecified
Severity: normal

Details

Reference
bz58623

Event Timeline

bzimport raised the priority of this task from to High.
bzimport set Reference to bz58623.
Legoktm created this task.Dec 18 2013, 4:29 AM

Change 102383 had a related patch set uploaded by Legoktm:
Don't show skin names if the user can't enable them

https://gerrit.wikimedia.org/r/102383

  • Bug 63151 has been marked as a duplicate of this bug. ***

Change 102383 merged by jenkins-bot:
Don't show skin names if the user can't enable them

https://gerrit.wikimedia.org/r/102383

Seb35 added a comment.Sep 13 2014, 2:08 PM

The current state on the Wikimedia project is without the names of the required skins. In the case it is wanted to keep the current state (for Wikimedia and/or for the master branch of BetaFeatures), this feature can be hidden with CSS, similarly to the browser requirements, by editing BetaFeatures/resources/betafeatures.less.

Seb35 added a comment.Sep 13 2014, 2:10 PM

Sorry, page error. This comment is for bug 70814.