Page MenuHomePhabricator

Special:IndexPages returns pages in the main namespace
Closed, ResolvedPublic

Description

Special:IndexPages returns pages in the main namespace:

https://fr.wikisource.org/w/index.php?title=Sp%C3%A9cial%3AIndexPages&limit=100&key=&order=size&sortascending=1

The 2 first resultats are:
https://fr.wikisource.org/wiki/Le_Corset_%C3%A0_travers_les_%C3%A2ges
https://fr.wikisource.org/wiki/Index_des_Planches_de_l%E2%80%99Encyclop%C3%A9die
which are not in the Index namespace.

Regards, Yann


Version: unspecified
Severity: normal

Details

Reference
bz58648

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 2:33 AM
bzimport added a project: ProofreadPage.
bzimport set Reference to bz58648.
bzimport added a subscriber: Unknown Object (MLST).
Yann created this task.Dec 18 2013, 3:52 PM

CONFIRMED

Observed the same on fr.wikisource. Don't see anything like that happening on en.wikisource however.

This might actually be a search bug...

GOIII added a subscriber: GOIII.Dec 12 2014, 3:06 AM

Worth mentioning...
both of the listed main-space works were moved from the Index: namespace to the main namespace at some point.

The latter retained a redirect from the Index: namespace; the redirect for the other one was deleted around the same time it was moved.

Don't know if this means anything but figure its worth documenting at the least.

Tpt added a comment.Mar 25 2015, 1:34 PM

The root issue is, I believe, that the search engine returns these pages even if there is a filter on the index namespace. So I add the seach engine project to this issue.

Tpt set Security to None.
555 added a subscriber: 555.Apr 29 2015, 10:31 PM
GOIII added a comment.Jul 10 2015, 4:40 AM

Well the Search project was removed since the last visit; so much for an answer coming from there.

For the sake of possible closure - can't someone with admin rights just re-create those 2 pages in question with similar titles, delete the existing ones and then move them over the deleted ones without importing any of the prior history (or something just as intuitive that will cause a similar [re]inventory & [re]listing)?

That's not really an answer for why this happened -- I know -- but I'm pretty sure its something that can no longer be replicated nowadays thanks to all the changes to the code & the extension since those 2 bad guys came into the main namespace.

Yann added a comment.Jul 10 2015, 9:01 AM

Effectively, deleting and recreating these pages fixed this issue.

Yann closed this task as Resolved.Jul 10 2015, 9:02 AM
GOIII moved this task from Backlog to Done on the ProofreadPage board.Jun 12 2016, 3:55 AM