Page MenuHomePhabricator

Flow: typing in long posts causes the screen to jump
Open, NormalPublic

Description

If you write a long Flow post (say, one where you can't see the top of the post area from the bottom), scroll to where you can no longer see the top, and type, it jumps you up again, hiding your text.


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=61937

Details

Reference
bz58657

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz58657.
bzimport added a subscriber: Unknown Object (MLST).

bingle-admin wrote:

The WMF core features team tracks this bug on Mingle card https://mingle.corp.wikimedia.org/projects/flow/cards/632, but people from the community are welcome to contribute here and in Gerrit.

This bug is still occurring.
To reproduce: Open a topic by itself,[1] reply to the bottom-most post, hit [enter] a few dozen times (to expand the text-area below the fold), then start typing.

Possibly the Front-end overhaul will solve this bug; but re-opening in the meantime, just for clarity.

[1] eg. https://www.mediawiki.org/w/index.php?title=Talk:Flow&workflow=rt5b1b6cu0s6h3bg

[1] eg. https://www.mediawiki.org/w/index.php?title=Talk:Sandbox&workflow=rug9buzgrpu4u395

(new example link, because the last one failed due to square brackets.)

Change 162363 had a related patch set uploaded by EBernhardson:
Set a maximum height to auto-expanding text fields

https://gerrit.wikimedia.org/r/162363

Change 162363 merged by jenkins-bot:
Set a maximum height to auto-expanding text fields

https://gerrit.wikimedia.org/r/162363

All patches mentioned in this report were merged or abandoned - is there more work left to do here (if yes: please reset the bug report status to NEW or ASSIGNED), or can you close this ticket as RESOLVED FIXED?

Quiddity removed a subscriber: Maryana.Dec 19 2014, 1:42 AM
Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 18 2018, 6:44 PM
SBisson moved this task from Inbox to Triaged but Future on the Growth-Team board.Jul 20 2018, 6:08 PM