Page MenuHomePhabricator

REPORTS-49 IP block SQL Query on en-wiki
Closed, DuplicatePublic

Description

This issue was converted from https://jira.toolserver.org/browse/REPORTS-49.
Summary: IP block SQL Query on en-wiki
Issue type: Task - A task that needs to be done.
Priority: Major
Status: Open
Assignee: River Tarnell <river.tarnell@wikimedia.de>

On Thu, 23 Oct 2008 13:18:04, brett hillebrand <server@internode.on.net> opened the following bug:

HI I would like a Query to be run on a monthly basis on the en-
wikipedia database. I want it to find all IPs that have had 5 or
more blocks and if possible, the last block being within the last
month. Im requesting this as a new measure of finding ips for
WP:ABUSE (abuse reports) Thanks User:Promethean


Version: unspecified
Severity: major

Details

Reference
bz58835

Related Objects

StatusAssignedTask
DuplicateNone
OpenNone

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 2:18 AM
bzimport added a project: Tool-tsreports.
bzimport set Reference to bz58835.

On Thu, 23 Oct 2008 13:54:07, DaB. <dab@ts.wikimedia.org> wrote:

Works with SELECT log_title, COUNT(log_title) AS count FROM
logging WHERE log_timestamp>20080101000000 AND log_type="block" AND
log_action="block" AND log_title REGEXP "^[0-9.]*$" GROUP BY
log_title ORDER By count DESC LIMIT 10;

valhallasw removed valhallasw as the assignee of this task.Dec 15 2014, 2:17 PM
valhallasw edited projects, added Quarry; removed Tool-tsreports.
valhallasw set Security to None.
Framawiki closed this task as a duplicate of T101835: Recurring queries.Apr 16 2018, 9:58 PM