Page MenuHomePhabricator

Migrate https://toolserver.org/~daniel/WikiSense/* to Tool Labs and provide redirect
Closed, DeclinedPublic

Description

Move https://toolserver.org/~daniel/WikiSense/CategoryIntersect.php to toolslabs.

Used as dependency on other scripts.

Details

Reference
bz58869

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 2:20 AM
bzimport added a project: Tools.
bzimport set Reference to bz58869.
bzimport added a subscriber: Unknown Object (MLST).

Hi,

Contributors.php now redirects to CatScan, which is not what users are looking for.

Best regards,

Hey folks! Sorry for the inconvenience. The WikiSense code is old and crufty, and not easy to port. Parts of it rely in nasty ways on some bits of some old version of MediaWiki... in a word, I'll try to get this done, but I can't promise when or which tools.

As to the redirect to CatScan: CatScan.php should now redirect to Magnus' catscan2 tool, which offers more or less the same functionality. The fact that other WikiSense tools now also redirect there now is a mistake. I'll try to get that fixed.

metatron wrote:

I can offer a working replacement.

eg. https://tools.wmflabs.org/xtools/articleinfo/?lang=de&wiki=wikipedia&page=Berlin&style=new

-> section Top editors

I you don't mind changing the redirect, temporarily until the issue is fixed or permanently, to ease the pain.

Set the redirect.

Nosy79 closed this task as Resolved.Dec 11 2014, 10:12 AM
Nosy79 set Security to None.

I'm confused: what was redirected to what?

Redirect 301 /~daniel/WikiSense/CatScan.php http://tools.wmflabs.org/catscan2/catscan2.php
Redirect 301 /~daniel/WikiSense/CategoryIntersect.php http://tools.wmflabs.org/catscan2/catscan2.php
Redirect 301 /~daniel/WikiSense/Contributors.php https://tools.wmflabs.org/xtools/articleinfo/
Redirect 301 /~daniel/WikiSense/ https://tools.wmflabs.org/wikisense/

Guess the last wikisense url is still under construction though...

He7d3r reopened this task as Open.Jun 15 2015, 11:16 AM
He7d3r added a subscriber: He7d3r.

So, we only have the redirect part of this request. The migration is not done, as we still get "No webservice" for
https://tools.wmflabs.org/wikisense/

I've restarted the webservice, but it seems Wikisense hasn't been migrated yet.

I've restarted the webservice, but it seems Wikisense hasn't been migrated yet.

And I'm quite sure Daniel isn't going to move it. Putting this one on stalled because I don't seen anyone getting up to do this.

Multichill changed the task status from Open to Stalled.Jun 15 2015, 1:52 PM
Multichill triaged this task as Lowest priority.
Multichill added a project: patch-welcome.

I've restarted the webservice, but it seems Wikisense hasn't been migrated yet.

Unfortunately, yes :(

Maybe it should be removed from :c:Commons:Tools .....

daniel closed this task as Declined.Jun 15 2015, 2:39 PM
daniel claimed this task.

I hereby officially declare WikiSense dead. Sorry folks.

There are far better replacements for most of the tools. Getting ten your old cruft op to speed is not worth the pain.

CatScan doesn't quite yet support the same use cases.

Steinsplitter added a subscriber: KasiaWMDE.EditedAug 26 2015, 2:02 PM

@KasiaWMDE: Can WMDE migrate this tool please? It is a very useful tool.
@daniel: Can you publish the source code please?

Steinsplitter reopened this task as Open.Aug 26 2015, 2:03 PM
Steinsplitter removed daniel as the assignee of this task.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 26 2015, 2:03 PM
Steinsplitter updated the task description. (Show Details)
Steinsplitter added a project: Commons.
Steinsplitter moved this task from Incoming to Third-party software on the Commons board.

@Steinsplitter Which tool, exactly? WikiSense was a collection of about 20 tools. Do you mean CatScan?

These tools were build on a very old version of MediaWiki. There is no sane way to migrate or port them. They would need a rewrite.

I suggest that you request the creation of the tools/functionality in a separate ticket.

daniel closed this task as Declined.Aug 26 2015, 2:09 PM
daniel claimed this task.

I close this as declined again, since the toolserver project "WikiSense", as created by me as a volunteer, will not be ported. I can dig out the source code from some old backup if need be, but I doubt that it would be very useful.

If you are missing some functionality that some WikiSense tool used to provide, please file a separate ticket describing the exact functionality you want.

You used a sql query to get the cats or how you do? It was api-only based?

If you publish the source code other users can look into it and try a rewrite.