Page MenuHomePhabricator

Flow: byte-count in special:contributions is incorrect
Closed, ResolvedPublic

Description

Example entry:

18:29, 30 December 2013 . . (+2,008)‎ . . Jay8g (talk | contribs | block) edited the board header.

He added three spaces ;p.


Version: unspecified
Severity: minor
See Also:
T62646: Flow bytes changed in watchlists is wrong

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 2:37 AM
bzimport set Reference to bz59138.
bzimport added a subscriber: Unknown Object (MLST).

bingle-admin wrote:

The WMF core features team tracks this bug on Mingle card https://mingle.corp.wikimedia.org/projects/flow/cards/664, but people from the community are welcome to contribute here and in Gerrit.

From #wikimedia-corefeatures, on 12-26-13:

[23:16:36] <legoktm> 05:43, 27 December 2013 (topic) . . (+1,117)‎ . . Legoktm (talk | contribs | block) added a comment.
[23:16:48] <legoktm> the comment was [[User:Maryana (WMF)|Maryana (WMF)]]: {{done}}!
[23:16:55] <legoktm> which is not 1117 bytes
[23:17:58] <+spagewmf> legoktm maybe that's the expanded template? Flow stores the HTML of expanded templates (while remembering the original wikitext for later editing)
[23:18:24] <+spagewmf> I keep asking if we explain this feature somewhere
[23:18:33] <legoktm> that would make sense then
[23:19:13] <legoktm> thats a weird UX though, because users will only ever deal with wikitext, not the raw HTML

Let's document this in a FAQ in the interim.

*** Bug 60646 has been marked as a duplicate of this bug. ***

Most of this is fixed; there's one more small error tracked in the backlog: https://trello.com/c/KlvyQzmz

He7d3r updated the task description. (Show Details)Feb 5 2015, 12:25 PM
He7d3r set Security to None.
He7d3r added a subscriber: He7d3r.Feb 5 2015, 12:27 PM

I observed the same problem at
https://pt.wikipedia.org/wiki/Special:Contribs/Quiddity_(WMF)?uselang=en

05:38, 5 February 2015 (diff | hist) . . (+1,771)‎ . . Wikipédia:Flow/Testes . . Quiddity (WMF) (Talk | contribs | block) edited topic summary on Mudanças recentes

Here, @Quiddity added {{Tarefa|T72595}}, whose length is 17.

https://gerrit.wikimedia.org/r/#/c/165683/ should fix this problem, but it hasn't been deployed there yet.
Once it is deployed, we should also still run the maintenance script to fix old entries.

Still present. See e.g. https://www.mediawiki.org/w/index.php?title=Talk:Flow&action=compare-header-revisions&header_newRevision=sbva9b44tgebuo2h (https://www.mediawiki.org/w/index.php?title=Talk:Flow&action=history).

No templates at all in the header. Text after the change:

The Collaboration team has enabled [[Flow_Portal|Flow]] on this talk page.

* Please conduct testing at [[Talk:Sandbox]], retaining this page for discussions and suggestions.
* If you find bugs not yet [https://phabricator.wikimedia.org/project/board/657/ tracked], [https://phabricator.wikimedia.org/maniphest/task/create/?projects=PHID-PROJ-ntg6sf6mfl2qm2e4qgxc report in Phabricator] if you can, and here if you can't.

Previous feedback is on [[Talk:Flow Portal/Archive2]] (using old Liquid Threads), and on our [http://ee-flow.wmflabs.org/wiki/Talk:Flow labs server].
(cur prev) 20:18, February 15, 2015 . . Mattflaschen (WMF) (talk | contribs) edited the header . . (+572)‎

Could still be a change to Parsoid, but that seems like a lot of bytes nonetheless.

hmm, i just did a test edit to same header adding two returns, and it shows up as +2. Tried editing the Talk:Sandbox header at mw.o and similar results(both changing text and adding a link). Will have to look closer and see what happened above, not immediatly able to duplicate

In T61138#1040427, @Mattflaschen wrote:

Could still be a change to Parsoid, but that seems like a lot of bytes nonetheless.

This is supposed to be a wikitext diff, so more verbose Parsoid HTML should not be able to cause this. Parsoid could only cause it if there were a dirty diff.

My addition of a template, that previously resulted in

05:38, 5 February 2015 (diff | hist) . . (+1,771)‎ . . Wikipédia:Flow/Testes . . Quiddity (WMF) (Talk | contribs | block) edited topic summary on Mudanças recentes

(per He7d3r's comment above)
now says

05:38, 5 February 2015 (diff | hist) . . (0)‎ . . Wikipédia:Flow/Testes . . Quiddity (WMF) (Talk | contribs) edited topic summary on Mudanças recentes

at https://pt.wikipedia.org/w/index.php?title=Especial:Contribui%C3%A7%C3%B5es/Quiddity_%28WMF%29&uselang=en


All old entries (prior to feb ~5) are showing up as 0 bytes, (E.g. ptwiki and cawiki and mw)


https://gerrit.wikimedia.org/r/#/c/165683/ should fix this problem, but it hasn't been deployed there yet.
Once it is deployed, we should also still run the maintenance script to fix old entries.

Did the maintenance script get run? Perhaps it needs to run again?

Change 192000 had a related patch set uploaded (by EBernhardson):
Properly handle interwiki in FlowUpdateRevisionContentLength

https://gerrit.wikimedia.org/r/192000

Patch-For-Review

It looks like the maint script was not properly handling having multiple wiki's in the same database. This new patch needs to be cherry picked forward and we need to re-run it for all wiki's that have flow.

matthiasmullie closed this task as Resolved.Feb 23 2015, 2:56 PM

Code has been merged.

Can't be product reviewed until we've actually run the script.
I've created T90443 to track that.

Change 192000 merged by jenkins-bot:
Properly handle interwiki in FlowUpdateRevisionContentLength

https://gerrit.wikimedia.org/r/192000