Page MenuHomePhabricator

Thanks given via mobile are not shown on desktop history page
Open, NormalPublic

Description

  1. Thank via mobile an edit done in a page you are watching. You get a confirmation message.
  2. Go to desktop, and check Special:Log/thanks to confirm that your thanks are there.
  3. Now go to your Watchlist.

EXPECTED

The edit you have thanks appears as thanked.

ACTUALLY

That edit still appears as "thankable", as if you wouldn't have thanked it before. Thanks given via mobile aren't registered in your watchlist. You will only find the thanks given via desktop.


Version: master
Severity: normal

Details

Reference
bz59207

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 2:15 AM
bzimport added a project: Thanks.
bzimport set Reference to bz59207.
bzimport added a subscriber: Unknown Object (MLST).
Qgil created this task.Jan 2 2014, 1:44 PM

Unsure if this is an issue in Thanks or MF...

Mobile rewrites the Watchlist so it's a mobile problem. Like a lot of websites, yes the watchlist view on mobile is not as feature rich as desktop (either intentionally or not intentionally). There is a tracking bug for these absent features.

  • This bug has been marked as a duplicate of bug 56817 ***
Qgil added a comment.Jan 8 2014, 5:12 AM

Just checking whether you understood the bug reported, as I fail to see what it has to do with the mobile watchlist:

(In reply to comment #0)

  1. Thank via mobile an edit done in a page you are watching. You get a

confirmation message.

  1. Go to desktop, and check Special:Log/thanks to confirm that your thanks

are
there.

This is clear. The thanks happens in a mobile diff page, not in the watchlist or the history.

  1. Now go to your Watchlist.

Sorry, here I meant the history of the page in desktop view, where "thank" / "thanked" options can be seen, not your mobile watchlist where no thanks status is displayed.

EXPECTED
The edit you have thanks appears as thanked.
ACTUALLY
That edit still appears as "thankable", as if you wouldn't have thanked it
before. Thanks given via mobile aren't registered in your watchlist. You will
only find the thanks given via desktop.

Let me insist that these expectations are based on the history of the page in desktop, not the mobile.

The thanks sent from mobile are properly logged at Special:Log/thanks, but there are two problems:

  • Thanks from mobile are not shown in page history.
  • MobileFrontend seems to have no memory at all about the Thanks sent. If you visit the same diff you have thanked (from mobile or desktop, it doesn't matter) then the button shown is always Thank, no Thanked.

For all these reasons I doubt this has anything to do with bug 56817 and the mobile watchlist.

Does the new title make more sense now (it might be worth reopening a clearer bug preferably with screenshots)?
I'll raise a separate bug for the memory problem.

See bug 59828

I'm pretty sure this is not an issue in MobileFrontend unless the API has changed (please feel free to bounce back)

matthiasmullie closed this task as Resolved.Dec 11 2014, 11:35 AM
matthiasmullie claimed this task.

Just tested, doesn't seem to be an issue anymore, worked for me.

I cannot test because... the Thanks button has vanished! I can't see it in my Firefox for Android. Weird.

Just tested, doesn't seem to be an issue anymore, worked for me.

Are you sure? Today I thanked this edit on mobile. On desktop still shows as "thankable".

Quiddity reopened this task as Open.Dec 23 2014, 10:04 PM

Confirmed, re-opening

@kaldari has said he will investigate.

Jdlrobson moved this task from 2014-15 Q2 to Upcoming on the Readers-Web-Backlog board.
Spage triaged this task as Normal priority.Dec 29 2014, 6:39 PM
Spage added a subscriber: Spage.
Jdlrobson moved this task from 2016-17 Q4 to Upcoming on the Readers-Web-Backlog board.
kaldari moved this task from 2016-17 Q4 to 2015-16 Q1 on the Readers-Web-Backlog board.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptAug 18 2015, 5:08 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
MaxSem removed a subscriber: MaxSem.Aug 18 2015, 5:13 PM
Jdlrobson set Security to None.

Code is in Thanks now

Florian removed a subscriber: Florian.Nov 4 2015, 6:49 PM
kaldari removed kaldari as the assignee of this task.Feb 11 2016, 3:37 AM
Restricted Application added a project: Growth-Team. · View Herald TranscriptSep 4 2018, 2:11 PM