Send two email notifications to active Bugzilla users asking them to join Phabricator
Closed, ResolvedPublic

Description

In T572#9466, @Qgil wrote:

What about this:

  • Send now an email to all Bugzilla users in the lines of "ACTION REQUIRED: JOIN PHABRICATOR", explaining that this is how you will have your Bugzilla history migrated to Phabricator on the launch date.
  • Send a second and last email to all Bugzilla users as we have a date confirmed, telling them the details about dates when the service will be down and a reminder about JOIN PHABRICATOR NOW, IT TAKES ONE MINUTE.

After agreeing on the idea (T572), Quim can draft the emails and get them reviewed. Then @Aklapper could send them on the dates agreed.

First email DRAFT, FEEDBACK AND EDITS WELCOME

  • Join Wikimedia Phabricator for a smooth Bugzilla migration **

    Dear Wikimedia Bugzilla user,

    https://phabricator.wikimedia.org will replace Bugzilla soon. We have released a preview with a sample of several thousands of Bugzilla reports automatically migrated. Your feedback is welcome.

    https://www.mediawiki.org/wiki/Phabricator/versus_Bugzilla#Test_instance

    If you have not created an account in Wikimedia Phabricator yet, please follow these steps now:

    Create your Phabricator account at https://phabricator.wikimedia.org/auth/start/ by clicking the "Login or Register - MediaWiki" button below the LDAP registration form. A dialog will be displayed saying "phabricator-production would like to have basic access on your behalf on all projects of this site." After clicking "Allow" you will see a "Phabricator Registration" dialog asking you to define a username in Phabricator, an email address, and a name (which does not have to be your real name). Afterwards, add the email address(es) that you have used in Bugzilla in https://phabricator.wikimedia.org/settings/panel/email/

    That's it! Your Bugzilla activity will be connected to your Phabricator username as soon as the migration from Bugzilla is completed.

    If you register an account after the Wikimedia Phabricator launch, you will still be able to claim your Bugzilla activity. However it will take us longer to connect your new username with your migrated data.

    Learn more about Phabricator at https://www.mediawiki.org/wiki/Phabricator

    IMPORTANT: Note that some Bugzilla data will not be migrated, like votes. You can find tickets that you have voted on at https://bugzilla.wikimedia.org/page.cgi?id=voting%2Fuser.html Furthermore, Bugzilla will still be available in read-only mode after the migration. Find all the details at https://www.mediawiki.org/wiki/Phabricator/versus_Bugzilla

    Questions? Just ask at https://www.mediawiki.org/wiki/Talk:Phabricator/Help

    You are receiving this email because you have been active in Wikimedia Bugzilla recently; we will send you one last reminder when we have a migration date confirmed.

    Thank you for your help!

    Andre Klapper (Wikimedia Bugwrangler)

Second email DRAFT, FEEDBACK AND EDITS WELCOME

Related Objects

There are a very large number of changes, so older changes are hidden. Show Older Changes
Qgil updated the task description. (Show Details)Oct 11 2014, 10:15 PM
Qgil moved this task from Waiting For Migration Start to Doing on the Bugzilla-Migration board.

@Aklapper, @gpaumier, @Quiddity (and others), please have a look at the draft email in the description and feel free to edit it or comment. I think we can send the email to the 2606 active Bugzilla users as soon as the text has been reviewed (where is this number coming from?).

Qgil raised the priority of this task from Normal to High.Oct 11 2014, 10:41 PM
Pine added a subscriber: Pine.Oct 13 2014, 7:31 AM

I am liking how Phabricator looks.

I have a few suggestions for the email announcement:

  1. Emphasize that "Real name" can == Wikimedia username. Users are not expected to compromise their privacy to join Phabricator.
  2. Encourage people to add their IRC nicks to their profiles.
  3. Provide a date when adding new bugs to Phabricator is ok (starting now?)
  4. Provide a date when Bugzilla will stop accepting new bugs
  5. Provide a date when Bugzilla will stop accepting changes to existing bugs

Thanks,
Pine

@Qgil The message looks good to me. Good job :) @Pine's suggestions make sense, but if you don't have a final calendar yet, it's ok to omit specific dates in this announcement imho.

Aklapper updated the task description. (Show Details)Oct 13 2014, 12:34 PM

Edited initial version a little; looks good to me!

In T618#10916, @Pine wrote:
  1. Provide a date when adding new bugs to Phabricator is ok (starting now?)

Depends on the project... Task creation in Phabricator has been available for a while but projects which are hosted in Bugzilla are in Bugzilla until Bugzilla is open. Only one bugtracker for a project.

  1. Provide a date when Bugzilla will stop accepting new bugs
  2. Provide a date when Bugzilla will stop accepting changes to existing bugs

Both will have the same date, also see T473.

Aklapper updated the task description. (Show Details)Oct 13 2014, 12:45 PM
Qgil added a comment.Oct 13 2014, 1:08 PM

I would remove the optional step 3. The email contains already plenty of information. The profile can be edited at any time, as many times as you wish.

Aklapper updated the task description. (Show Details)Oct 13 2014, 3:00 PM
In T618#10941, @Qgil wrote:

I would remove the optional step 3. The email contains already plenty of information. The profile can be edited at any time, as many times as you wish.

Makes sense. Done.

Qgil reassigned this task from Qgil to Aklapper.Oct 13 2014, 4:56 PM

This text looks good. All your, Andre!

PS: I still think that song your role in the signature will make things clearer. :)

Aklapper updated the task description. (Show Details)Oct 13 2014, 6:36 PM
Qgil awarded a token.Oct 13 2014, 7:28 PM

I think it is important to have mentioned that someone should connect his account to his SUL account, with result that there is a link to the user page on MediaWiki.

Tgr added a subscriber: Tgr.Oct 15 2014, 9:39 AM

Send now an email to all Bugzilla users in the lines of "ACTION REQUIRED: JOIN PHABRICATOR"

If not prohibitively hard, you should filter out email addresses which are already attached to a Phabricator account.

Otherwise, you should add a line explaining that this email is sent to everyone and receiving it does not necessarily mean that they didn't manage to migrate their account so far.

revi added a subscriber: revi.Oct 15 2014, 10:25 AM
He7d3r added a subscriber: He7d3r.Oct 15 2014, 12:21 PM
In T618#11231, @Tgr wrote:

If not prohibitively hard, you should filter out email addresses which are already attached to a Phabricator account.

Probably not possible as there's no way to see email addresses of users already registered...
https://phabricator.wikimedia.org/people/query/all/

Otherwise, you should add a line explaining that this email is sent to everyone and receiving it does not necessarily mean that they didn't manage to migrate their account so far.

Very good point, I'll add that to the draft! Thanks!

Aklapper updated the task description. (Show Details)Oct 15 2014, 6:31 PM

Chase proposed to send this email out once T552 (testing instance with imported data) is up which should take another 2-4 working days.
Then we could also include a link to that test instance to allow people to take a look at it and provide feedback (where?).

Qgil added a comment.Oct 15 2014, 8:49 PM

Coupling the first email with availability of the preview is a very good idea.

About where to post feedback, what about defaulting to https://mediawiki.org/wiki/Talk:Phabricator/versus_Bugzilla ? Andre, myself, and whoever else wants to help can process the feedback, and file tasks or comments when needed.

Qgil updated the task description. (Show Details)Oct 23 2014, 8:00 PM

I've requested those Bugzilla user email addresses in https://rt.wikimedia.org/Ticket/Display.html?id=8724.

Bugzilla DB SQL query I came up with: SELECT distinct profiles.login_name FROM logincookies JOIN profiles ON logincookies.userid = profiles.userid WHERE logincookies.lastused > '2013-10-24 00:00:00';

Announcement made. Green light to send the first email to the active Bugzilla users.

SELECT distinct profiles.login_name FROM logincookies JOIN profiles ON logincookies.userid = profiles.userid WHERE logincookies.lastused > '2013-10-24 00:00:00';

And yes, that query is different from T559#9670...

Aklapper updated the task description. (Show Details)Oct 24 2014, 9:44 PM

Edited the task description to be more verbose based on feedback: Mention to use the "MediaWiki" button instead of LDAP; "real name" does not have to be a real name.

https://rt.wikimedia.org/Ticket/Display.html?id=8724 is resolved thanks to mutante: 846 users to inform who logged into Bugzilla in the last 12 months.

Qgil updated the task description. (Show Details)Oct 24 2014, 9:59 PM

Another little edit, also based on feedback.

Good to go!

Aklapper lowered the priority of this task from High to Normal.Oct 24 2014, 11:03 PM

I have sent the first announcement email to 846 users (in BCC; To set to myself); after looking up https://support.google.com/a/answer/166852

I am tempted to merge T390 into this task...

Qgil updated the task description. (Show Details)Nov 3 2014, 11:36 AM

Indeed. Merging.

Now the information about votes is more precise. I have also cut the specific instructions about the registration. The link to the help should be just as useful.

If you want to receive notifications about bugs you voted, you will need to subscribe to them manually after the migration. You can find the tickets that you have voted on

Better, thanks, but still useless. How do I find the bugs I voted which I wasn't cc'd to? We're certainly not telling users to manually open them one by one, are we? (Personally I'll do some regex cleanup of the votes list, enter the list of IDs in advanced search, filter by bugs I'm not cc'd on. But most users are not able to do any of these.)

Speaking of which, is there an interface for bulk bug changes on phabricator?

Tgr added a comment.Nov 4 2014, 9:25 AM

Better, thanks, but still useless. How do I find the bugs I voted which I wasn't cc'd to? We're certainly not telling users to manually open them one by one, are we? (Personally I'll do some regex cleanup of the votes list, enter the list of IDs in advanced search, filter by bugs I'm not cc'd on. But most users are not able to do any of these.)

Go to the "My votes" page and click on "view all as bug list" on the bottom to get a comma-separated list of bug ids.

In Phabricator, go to Maniphest, Advanced search, enter the comma-separated list into the bugzilla id field (which doesn't seem to exist yet), click "Execute query", at the bottom click "Select all", "Batch edit selected", select "Add CCs" from the dropdown, add your username, click "Update tasks".

If you need to filter out bugs you are CCd on, you can edit the bugzilla search, but then it's more complicated to extract the results (probably need to export to CSV and do some text processing). But if you just want to CC to all the bugs you have voted for, that's not needed.

How do I find the bugs I voted which I wasn't cc'd to?

No way that I am aware of, plus I don't see an obvious reason why you'd suddenly want to receive mail notifications for a ticket that you had voted on. Wasn't the whole argumentation of (ab)using Bugzilla's voting as some kind of "watchlist" that you didn't want to receive mail notifications? Also see T264.

We're certainly not telling users to manually open them one by one, are we?

I'm telling users that their Bugzilla votes won't be migrated to Phabricator. I don't tell anybody to open anything. :)

...and I'd like to give a token to Tgr just for his comment. Good idea!

Qgil added a comment.Nov 7 2014, 9:25 PM

What about sending the second email during Thursday 13 Nov (or Friday 14 00:30 UTC if you wish), one week before the planned start of the migration?

"One week" sounds immediate enough, yet it gives more than enough time for anything a user needs to do with Bugzilla.

Aklapper raised the priority of this task from Normal to High.Nov 12 2014, 1:22 AM
In T618#20042, @Qgil wrote:

What about sending the second email during Thursday 13 Nov (or Friday 14 00:30 UTC if you wish), one week before the planned start of the migration?

Sounds good.

Qgil updated the task description. (Show Details)Nov 13 2014, 9:55 AM
Aklapper updated the task description. (Show Details)Nov 13 2014, 11:06 AM
Qgil updated the task description. (Show Details)Nov 13 2014, 12:20 PM
Aklapper updated the task description. (Show Details)Nov 13 2014, 4:05 PM
Aklapper updated the task description. (Show Details)
Aklapper closed this task as Resolved.Nov 14 2014, 3:09 AM
Qgil added a comment.Nov 14 2014, 7:24 AM

Has anybody received this second email? I can't find it in my mailbox, and I did receive the first one.

I got the second one

Qgil added a comment.Nov 14 2014, 10:12 AM

Either I'm blind or the second notification is nowhere to be seen in my mailbox (yes, spam folder included). Hopefully it is just me... @Aklapper, do you have a way to check how many recipients did you use this time, and whether you got more bounces/errors than last time?

I mean, if it's just me and a few others, this is not problematic. But if half the users haven't received it... at least we should know.

@Qgil: Number of bounces was slightly larger this time than first time. Recipients list was same as last time (I see your address in BCC of the 4th email I sent around 02:13UTC; each email=50 recipients).

I realised that the information contained in the second email was sub-optimal.

If you want to receive notifications about bugs you voted, you will need to subscribe to them manually after the migration. You can find the tickets that you have voted on at https://bugzilla.wikimedia.org/page.cgi?id=voting%2Fuser.html

This is not a good advice. What I did instead:

  1. https://bugzilla.wikimedia.org/page.cgi?id=voting%2Fuser.html
  2. Click "view all as bug list" at the bottom
  3. Click "Change Several Bugs at Once" at the bottom
  4. Click "Check All" at the end of the list
  5. Write my email in the "CC List:" field
  6. Click "Commit" at the bottom

So my subscriptions will be migrated together with bugzilla data. Phabricator doesn't offer any easy to use feature for such a job, AFAICS.

IMHO worth sending a separate email with subject "Migrate your Wikimedia bugzilla votes now" to all the users who ever voted a bug. Ideally we'd also provide the link from step (2) (or even an HTML save of it) but that would require some work.

The instructions in T618#18534 above are already linked from https://www.mediawiki.org/wiki/Phabricator/versus_Bugzilla#Bugzilla_data_migrated

But the email only linked another section and for unrelated purposes ("Find all the details about the differences"), so I didn't reach said instructions. Moreover, due to T624 it's much better to perform batch changes on bugzilla, which is less spammy.

IMHO worth sending a separate email with subject "Migrate your Wikimedia bugzilla votes now" to all the users who ever voted a bug.

I've requested that data in https://rt.wikimedia.org/Ticket/Display.html?id=8886 and that's about 4000 users who have ever voted. And then I realized....

  1. Click "Change Several Bugs at Once" at the bottom

...this step requires "editbugs" permissions.

@Nemo_bis: So if we sent such a message, the included instructions wouldn't work for approx. half of the recipients.

Nemo_bis added a comment.EditedDec 12 2014, 7:33 AM

So if we sent such a message, the included instructions wouldn't work for approx. half of the recipients.

We could just give editbugs to everyone in old-bugzilla.

enter the comma-separated list into the bugzilla id field (which doesn't seem to exist yet)

And still doesn't exist, or not as you imagined it. So the only option is to take the bugzilla ID, put them in a spreadsheet, add 2000 on each row, take the new list of IDs, put into "task IDs" field. Heh, imagine if T857 had not been partially fixed! Can still be improved by fixing T857 completely though (or by giving us a really-advanced and really-userfriendly search like bugzilla's).