Page MenuHomePhabricator

can't configure existing instance, claims requested host does not exist
Closed, ResolvedPublic

Description

I just created a fresh instance:

i-00000a1f

in project wikistats

It built just normal, i can see it in Special:NovaInstance, syslog looks like it's all done , i can connect to it via ssh, and so on, yet when i try to configure it, it claims:

"The requested host does not exist. "

https://wikitech.wikimedia.org/w/index.php?title=Special:NovaInstance&action=configure&instanceid=d1788ff4-f770-412f-9b86-640ea2064919&project=wikistats&region=pmtpa


Version: unspecified
Severity: major

Details

Reference
bz60167

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 3:02 AM
bzimport added a project: Cloud-VPS.
bzimport set Reference to bz60167.
bzimport added a subscriber: Unknown Object (MLST).
Dzahn created this task.Jan 17 2014, 12:52 PM

addition: it happens on all instance in that project, no matter if they are old or just created

Dzahn added a comment.Jan 17 2014, 1:10 PM

petan confirmed he is getting the same error on other projects, so it seems global and therefore i raised severity to major

coren added a comment.Jan 17 2014, 2:26 PM

The mw code deployed on virt0 (Wikitech) currently appears at least partly broken; I'm going to wait until I grab a hold of Ryan and/or Mike to see if this is a deploy-in-progress they are working on or revert it otherwise.

Change 108046 had a related patch set uploaded by Hashar:
Specia::NovaInstance missed region support

https://gerrit.wikimedia.org/r/108046

Change 108046 merged by jenkins-bot:
Special::NovaInstance missed region support

https://gerrit.wikimedia.org/r/108046

coren added a comment.Jan 17 2014, 3:30 PM

The fix does allow configuration of instances again.

Dzahn added a comment.Jan 17 2014, 4:06 PM

confirmed, working again. awesome, thanks for the quick fix!