Page MenuHomePhabricator

BiDi: Firefox: "Move page:" and "To new title:" show different titles
Closed, InvalidPublic

Description

Author: gangleri

Description:
Hallo!

screen dump will follow

I have chosen Component "General/Unknown" because I have seen somthing similar
to this related at "copy and paste" using Windows XP SP 2 and Mozilla Firefox
showing similar behaviour. This will be reported later.

Please go to
http://test.leuksman.com/index.php?title=Special:Userlogin
log in and "start" the "move" peocedure
http://test.leuksman.com/view/Special:Movepage/User:%E2%80%AA%E2%80%AB%D7%92%D7%90%D6%B7%D7%A0%D7%92%D7%9C%D7%A2%D7%A8%D7%99_4%E2%80%AC%E2%80%AC
Please revert the change if you realy move the page.

You can see that
"Move page:" and
"To new title:" are different

This does not happen with IE.

If you can confirm this bug please specify your operating system and browser.
Thanks in advance!

best regards reinhardt [[user:gangleri]]


Version: unspecified
Severity: minor
OS: Windows XP
Platform: PC
URL: http://test.leuksman.com/view/Special:Movepage/User:%E2%80%AA%E2%80%AB%D7%92%D7%90%D6%B7%D7%A0%D7%92%D7%9C%D7%A2%D7%A8%D7%99_4%E2%80%AC%E2%80%AC

Details

Reference
bz4223

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 8:59 PM
bzimport added a project: MediaWiki-General.
bzimport set Reference to bz4223.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Dec 8 2005, 9:04 PM

gangleri wrote:

screen dump for bug 04223

Attached:

DaB wrote:

ok. I can see the bug with firefox 1.0.7 on debian too. But if I try to move the
page, the "You couldn't move. Source and Destination are the same"-error will come.

DaB.

gangleri wrote:

(In reply to comment #0)

I have chosen Component "General/Unknown" because I have seen somthing similar
to this related at "copy and paste" using Windows XP SP 2 and Mozilla Firefox
showing similar behaviour. This will be reported later.

see
Bug 4224: BiDi: strange results when using "copy and paste" in (Windows XP SP 2
and) Firefox

Looking at the article sourcecode with vi (which escape unknown stuff
with '<####>') I got:

<h1 class="firstHeading"><202a><202b>גאַנגלערי 4<202c><202c></h1>

I then look at the move request sourcecode:

<td align='right'>Move page:</td>
<td align='left'><strong><202a><202b>גאַנגלערי 4<202c><202c></strong></td>

And then:
<input type='text' size='40' name='wpNewTitle' id='wpNewTitle'
value="<202a><202b>גאַנגלערי 4<202c><202c>" />
<input type='hidden' name="wpOldTitle" value="<202a><202b>גאַנגלערי 4<202c><202c>" />

It is a firefox bug and I am afraid there is nothing we are going to do.

Issue with firefox. Please open a bug at:
https://bugzilla.mozilla.org/

Restricted Application added a project: I18n. · View Herald TranscriptJun 2 2015, 2:21 PM