Page MenuHomePhabricator

RTL characters disappear in the Search edit box at Special:Search
Closed, InvalidPublic

Description

Author: gangleri

Description:
Hallo!

This bug is related to Mozilla Firefox. I am using Windows XP. IE works fine. The behaviour
was confirmed on IRC.

a) Please go to
http://he.wikipedia.org/wiki/Main_Page?uselang=en
b) *copy* three alephs
אאא
c) inserte them in the "Search" field and inserte click on "Search"
d) you are now at
http://he.wikipedia.org/wiki/special:Search?search=%D7%90%D7%90%D7%90&fulltext=Search
e) append "&uselang=en" to the url in order to receive
http://he.wikipedia.org/wiki/special:Search?search=%D7%90%D7%90%D7%90
&fulltext=Search&uselang=en

and in order to see the page with the en: user interface

f) please look at *both* editboxes in the main area (not between the navigation area and
toolbox)
g) inside the editbox at the *top* are only *two* alephs; THIS is the bug.

inside the editbox at the *bottom* are three alephs same as between the navigation area and

toolbox
h) you are now at
http://he.wikipedia.org/w/index.php?title=Special%3ASearch&search=%D7%90%D7%90%D7%90&fulltext=%
D7%97%D7%A4%D7%A9
i) append "&uselang=en" to the url in order to receive
http://he.wikipedia.org/w/index.php?title=Special%3ASearch&search=%D7%90%D7%90%D7%90&fulltext=%
D7%97%D7%A4%D7%A9&uselang=en

and in order to see the page with the en: user interface

j) tray steps a) to g) *without* using "&uselang=en" and / or with "&uselang=he"
k) tray the same with latin characters "abc", Cyrillic characters etc. and report errors here.
l) tray the same in IE

This was mentioned in bug 03615 comment 9 f).

Please add other OS and / or browser configurations where you can / can not reproduce the
error. Thanks in advance!

Best regards reinhardt [[user:gangleri]]


Version: unspecified
Severity: normal
Platform: PC
URL: http://he.wikipedia.org/wiki/special:Search?search=%D7%90%D7%90%D7%90&fulltext=Search

Details

Reference
bz4332

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 9:00 PM
bzimport added a project: MediaWiki-Search.
bzimport set Reference to bz4332.
bzimport added a subscriber: Unknown Object (MLST).

gangleri wrote:

(In reply to comment #0)

This bug is related to Mozilla Firefox. I am using Windows XP. IE works fine. The

behaviour was confirmed on IRC.

using Windows XP SP 2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

*dependencies*
adding: blocks 745, 1381

zigger wrote:

g) works for me (אאא in both boxes), using "Mozilla/5.0 (Windows; U; Windows NT
5.1; en-GB; rv:1.8) Gecko/20051107 Firefox/1.5".

spacebirdy wrote:

Strange, it worked for me with 3, but with four, same bug as mentioned above:
I used 4 alephs: הקשר, when I klicked on "search" (not go!) there were only 3 in
the upper box left:
קשר
But in order to copy them here I found out that the first one was hidden inside
the box (it has "scrolled") with my mouse I could (by pressing the mouse botton
and selecting it) make it visible again.

Best regards, birdy

spacebirdy wrote:

(In reply to comment #3)
Windows 2000, firefox 1.5

gangleri wrote:

(In reply to comment #3)

... I used 4 alephs: ...
... (it has "scrolled") ...

Thank you Elisabeth for the test and the hint. If I start with
אאאא
I will see first only *three* alephs but if I scroll I will see *four* alephs too.

Traying to identify this bugzilla.mozilla.org bug trough irc://irc.mozilla.org/BiDi.

spacebirdy wrote:

(In reply to comment #5)
I tried again with 3 because I just got the idea there might be a relation to
the size of the browser window. If I resize my browser window, I can make all 3
alephs disappear. Only in the upper box.
Greetings, birdy

gangleri wrote:

this bug is reported at bugzilla.mozilla.org
https://bugzilla.mozilla.org/show_bug.cgi?id=191635#c7
Bug [Bugzilla] 191635 == Text of text box not showing up

It is fixed in "nightly trunk". Download url:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

see also
https://bugzilla.mozilla.org/show_bug.cgi?id=182107#c19 and
https://bugzilla.mozilla.org/show_bug.cgi?id=182107#c20
Bug [Bugzilla] 182107 == A div with a z-index of -1 causes the text of form
elements it sits behind to become transparent

zigger wrote:

(re-opening to fix resolution: apparently this is a mozilla bug, not mediawiki)

Restricted Application added a project: I18n. · View Herald TranscriptJun 2 2015, 2:22 PM
Restricted Application added a project: Discovery. · View Herald TranscriptFeb 14 2016, 1:21 AM