Page MenuHomePhabricator

FuzzyBot edit wars with itself on some /en pages after a page is marked, for a minute and some edits
Closed, ResolvedPublic

Description

The most obvious example is on https://meta.wikimedia.org/w/index.php?title=Confidentiality_agreement_for_nonpublic_information/en&action=history

It made 15 back and forth edits on the most recent push but looking through the history it seems to have done it a couple times before as well (but not always the same amount).


URL: https://meta.wikimedia.org/w/index.php?title=Special:Contributions/FuzzyBot&offset=20140214120000&namespace=0&target=FuzzyBot
See Also:
T48716: Translation page does not contain the latest translations/last translation

Details

Reference
bz61353
Related Gerrit Patches:

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 2:52 AM
bzimport set Reference to bz61353.
bzimport added a subscriber: Unknown Object (MLST).

That's definitely an entry for [[WP:LAME]].

Two of the examples I saw are about tvar, the other about a space.

  • Bug 62137 has been marked as a duplicate of this bug. ***
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 23 2016, 8:04 AM

This is because when the translation units are updated by FuzzyBot, the page is re-rendered for each unit repeatedly. https://gerrit.wikimedia.org/r/#/c/281698/ will make it stop do that and render it only once after updating all the units.

Change 281698 had a related patch set uploaded (by Glaisher):
Move several updates to TranslationsUpdateJob when page is marked for translation

https://gerrit.wikimedia.org/r/281698

Change 281698 merged by jenkins-bot:
Move several updates to TranslationsUpdateJob when page is marked for translation

https://gerrit.wikimedia.org/r/281698

Glaisher closed this task as Resolved.Apr 13 2016, 1:11 PM
Glaisher claimed this task.
Nikerabbit updated the task description. (Show Details)
Nikerabbit moved this task from Backlog to Done on the Language-Q4-2016-Sprint 1 board.