Page MenuHomePhabricator

sometimes transcode jobs will be queued on upload but never run
Closed, InvalidPublic

Description

Unclear if this is TMH or job queue issue or what.

Sometimes certain video/audio files on upload will have transcode jobs be "queued" (according to [[commons:Special:TimedMediaHandler]]) but they never run until someone presses reset transcode. This only happens rarely, a couple files a day. Most files have their transcodes run fine.

Most recent example is: https://commons.wikimedia.org/wiki/File:Wikimania_HongKong_2013_by_Olaf_Kosinsky_Video_13.ogv I've seen several other examples (gone now as I pressed reset transcodes)


Version: unspecified
Severity: normal

Details

Reference
bz61401

Event Timeline

bzimport raised the priority of this task from to Needs Triage.
bzimport set Reference to bz61401.
Bawolff created this task.Feb 14 2014, 11:15 PM

Change 133994 had a related patch set uploaded by Brian Wolff:
Automatically re-add transcode jobs if transcode pending for 72h

https://gerrit.wikimedia.org/r/133994

Gilles triaged this task as Normal priority.Nov 24 2014, 1:25 PM
Gilles added a subscriber: Gilles.
brion added a subscriber: brion.Jul 21 2015, 1:02 AM
Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptJul 21 2015, 1:02 AM
Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:36 PM

Change 133994 had a related patch set uploaded (by Paladox):
Automatically re-add transcode jobs if transcode pending for 72h

https://gerrit.wikimedia.org/r/133994

Change 133994 abandoned by TheDJ:
Automatically re-add transcode jobs if transcode pending for 72h

Reason:
Because brion in T49312 states that he is no longer seeing these types of failures.

https://gerrit.wikimedia.org/r/133994

TheDJ closed this task as Invalid.Nov 19 2015, 12:08 PM
TheDJ claimed this task.
TheDJ added a subscriber: TheDJ.

Provisionally closing. Likely caused by the same root cause as T49312, but these failures should now be detectable.