Page MenuHomePhabricator

normal diff links don't redirect to MobileDiff
Closed, InvalidPublic

Description

When opening a diff link on mobile (such as one from a watchlist email), the desktop view is used.

For diffs between adjacent revisions at least (until MobileDiff can handle multipe-edit-diffs), diff links should redirect to the mobile view.

This would make my mobile workflow 10x better. I want to be able go from a watchlist email straight to the mobile diff view (and then thank people for good edits, yay!).


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=70312

Details

Reference
bz61489

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 3:02 AM
bzimport set Reference to bz61489.
bzimport added a subscriber: Unknown Object (MLST).
Ragesoss created this task.Feb 18 2014, 2:07 PM

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Mingle card https://wikimedia.mingle.thoughtworks.com/projects/mobile/cards/1710

Change 148613 had a related patch set uploaded by Florianschmidtwelzow:
Redirect to mobile diff page

https://gerrit.wikimedia.org/r/148613

Seems to be fixed now. If there are still any discrepancies, let me know.

Opps, wrong bug :P

Change 148613 merged by jenkins-bot:
Redirect to mobile diff page

https://gerrit.wikimedia.org/r/148613

Apparently, there were two separate issues with this bug:

  1. We weren't trying to redirect regular diffs to the MobileDiff view (this is fixed by https://gerrit.wikimedia.org/r/148613)
  2. Non-canonical URLs do not get redirected to mobile by Varnish on purpose (so as not to cause problems with certain API calls, etc.) This is bug 70312.

Bug 70312 is a WONTFIX, so what we actually need to do now is reduce the number of interfaces that create non-canonical diff links in MediaWiki, especially when those links are likely to be used on a mobile device.

Sage: Do you remember where the link you were trying to follow came from? Echo maybe?

What is the current situation with this?

I think we took this discussion to IRC back in September, but the current situation is that it's still an issue.

The main place where I get these non-redirected links on a daily basis is from watchlist emails. So I guess the solution is to have those watchlist emails send canonical urls?

@Ragesoss can you paste a sample URL that is not redirecting? Thanks :D

Thanks a bunch Sage! :)

Oop seems to be captured here: T72318

Jdlrobson closed this task as Invalid.Dec 10 2014, 8:55 PM
Jdlrobson claimed this task.

Duplicate of T72318