Using the language link tool in the sidebar when inside VisualEditor loses the edit without warning
OpenPublic

Description

A user at en.wp reported today that you can add interlanguage links while you're in VE. The last step when doing so means the whole page gets reloaded, so whatever was done in VE until that moment gets lost. I am not aware of ways to prevent this, and there is no indication in VE that this will happen when you start that procedure.


Version: unspecified
Severity: normal
Whiteboard: u=dev c=backend p=0
See Also:
T54105: VisualEditor: Ability to edit language links on Wikidata from within the editor

bzimport added a subscriber: Unknown Object (MLST).
bzimport set Reference to bz62005.
Elitre created this task.Via LegacyFeb 27 2014, 5:02 PM
Jdforrester-WMF added a comment.Via ConduitFeb 27 2014, 5:08 PM

Wikidata bug, not VE bug.

Elitre added a comment.Via ConduitFeb 27 2014, 5:10 PM

(Filed initially as WD, thought you hadn't mentioned this detail, re-filed again as VE. Close enough.)

Lydia_Pintscher added a project: Wikidata.Via WebDec 1 2014, 2:46 PM
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
matej_suchanek edited the task description. (Show Details)Via WebMon, Jun 15, 12:35 PM
matej_suchanek added a project: VisualEditor.
matej_suchanek set Security to None.
Jdforrester-WMF moved this task to TR4: Link editor tweaks on the VisualEditor workboard.Via WebThu, Jun 18, 12:53 AM
Jdforrester-WMF moved this task to Backlog on the VisualEditor workboard.

Add Comment