Page MenuHomePhabricator

Mobile frontend Uploader doesn't give error message on error
Closed, ResolvedPublic

Description

Reported by Gryllida on commons:

Steps to reproduce:
*Go to https://commons.m.wikimedia.org/wiki/Special:Uploads
*Select contribute an image
*In the file selector, select a file that is in a format not allowed at commons, or a file that would otherwise be rejected (e.g. A JPG file that mime type detects to something that's not a jpg)

Expected behaviour:
*User is presented with an error. Something along the lines of "Invalid file, please try something else. Valid formats are X"

Actual behaviour:
*User is immediately returned to the list of images they had previously uploaded, with no indication what went wrong, or even if anything went wrong.


Version: unspecified
Severity: normal

Details

Reference
bz62034

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:03 AM
bzimport set Reference to bz62034.
bzimport added a subscriber: Unknown Object (MLST).
Bawolff created this task.Feb 28 2014, 4:00 AM

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Mingle card https://wikimedia.mingle.thoughtworks.com/projects/mobile/cards/1736

Interestingly works fine for lead photo uploads but not on Special:Uploads. Investigating.

Change 116181 had a related patch set uploaded by Jdlrobson:
Ensure a toast shows when uploading an invalid file

https://gerrit.wikimedia.org/r/116181

Change 116181 merged by jenkins-bot:
Ensure a toast shows when uploading an invalid file

https://gerrit.wikimedia.org/r/116181