Page MenuHomePhabricator

VisualEditor: Save dialog throws "Uncaught TypeError: Cannot read get getModel of undefined" (IE9)
Closed, ResolvedPublic1 Story Points

Description

Screenshot of bug.

Encountered in IE9 using BrowserStack "Windows 7/IE9" using latest MediaWiki and VisualEditor master via a tunnel. Could either be a browser bug we have to work around, or something on our end applicable to other browsers as well.

  • Edit a simple document.
  • Add two characters at the start.
  • "Save page" enables itself.
  • Click it.

Uncaught exception:

“Unable to get value of property ‘getModel’: object is null or undefined”.


Version: unspecified
Severity: normal

Attached:

Details

Reference
bz62334

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:05 AM
bzimport set Reference to bz62334.
Krinkle created this task.Mar 6 2014, 5:53 PM

I'm unable to reproduce this bug because before it even gets anywhere, I get bug 63039 first:

"SCRIPT70: Permission denied", /Main_Page, line 1 character 1

Jdforrester-WMF lowered the priority of this task from High to Low.Jan 9 2015, 10:33 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 14 2016, 5:25 PM

I get bug 63039 first:

Which is T65039 and has a patch for review.

Esanders closed this task as Resolved.Apr 20 2016, 10:35 AM
Esanders claimed this task.

Works now.

Jdforrester-WMF set the point value for this task to 1.Apr 25 2016, 3:16 PM
Jdforrester-WMF set Security to None.
Jdforrester-WMF moved this task from Freezer to TR0: Interrupt on the VisualEditor board.