Page MenuHomePhabricator

VisualEditor: Provide a clean interface for rendering detached CE nodes
Closed, ResolvedPublic

Description

In ve.ce.MWTreferenceListNode we do something quite evil, which is creating a one-off CE node, adding it's $element to the DOM, then destroying it. This happens to work because destroy doesn't abort async rendering processes, but in the future this may change. It's also quite messy to do things this way, and all we really need is a simple way to get a rendering from a model.


Version: unspecified
Severity: enhancement

Details

Reference
bz62682

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 2:53 AM
bzimport added a project: Technical-Debt.
bzimport set Reference to bz62682.
Jdforrester-WMF lowered the priority of this task from High to Medium.Jan 9 2015, 10:55 PM
matmarex closed this task as Resolved.Feb 3 2020, 9:25 AM
matmarex added a subscriber: matmarex.

ve.ui.PreviewElement probably fits the bill here. See T94130 (which might have been a duplicate of this).

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptFeb 3 2020, 9:25 AM