Page MenuHomePhabricator

VisualEditor: IE9 doesn't load new page when when re-editing a page modified in another browser
Closed, InvalidPublic

Description

To reproduce:

  1. Load a page in IE in the visual editor.
  2. Load the same page in another browser, make a change, and save it.
  3. Load the page view in IE, confirm you can see the edit.
  4. Click "Edit" to enable the visual editor. Old content appears in the editor.
  5. Quit IE and restart. Load page to edit in VE. See new content in the editor.

Initially I thought this was simply a server configuration issue (and maybe it still is), but I tested the same thing in FF and got the new page.


Version: unspecified
Severity: normal

Details

Reference
bz63048

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:00 AM
bzimport set Reference to bz63048.
Jdforrester-WMF lowered the priority of this task from High to Low.Jan 9 2015, 10:33 PM

Is this still a problem? Sounds like IE is caching wrongly?

Krenair writes:

Is this still a problem? Sounds like IE is caching wrongly?

I doubt this is a problem now since {T74480: MediaWiki API Cache-Control headers are different than MediaWiki's which causes problems for VE users on some browsers} is resolved.

Krenair closed this task as Invalid.Jul 15 2015, 9:45 PM
Krenair claimed this task.

Sounds like it may have been resolved in another task, so resolving invalid. Please reopen if this is still an issue