Page MenuHomePhabricator

Support core-0-mostused with JSON file format
Closed, ResolvedPublic

Description

Currently the mostused sub group for MediaWiki core can't be supported, as it requires PHP arrays. It should be able to use the new JSON format for MediaWiki core.


Version: master
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=63416

Details

Reference
bz63415

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 3:07 AM
bzimport set Reference to bz63415.
bzimport added a subscriber: Unknown Object (MLST).
siebrand created this task.Apr 2 2014, 1:45 PM
  • Bug 64223 has been marked as a duplicate of this bug. ***

Please do not change Priority of you are not planning on Working on this issue.

Writing the new message group shouldn't take more than hour, but we also need updated data for it. Is there separate bug for that yet?

There isn't urgent need to fix this before 63416 is resolved.

Gerard.meijssen wrote:

Hoi,
It is a requirement for new languages in the language policy. Consequently there IS an urgent need to have the most used messages available.
Thanks,

GerardM

(In reply to Gerard Meijssen from comment #5)

It is a requirement for new languages in the language policy. Consequently
there IS an urgent need to have the most used messages available.

Agreed. The 2011 list might be only 75 % correct now, but it's still vastly better than random guessing (currently 500/3057 = 16.4 % chance).

Niklas, can you remove bug 63416 from blockers?

Nemo, I think you are asking me to restore the old list, which is not what this bug is about.

Gerard has expressed interest to work on this bug so he can remove the blocker if he sees fit. I am referring to comment #2 here ;)

In my opinion the old list is *not* more useful than translating certain percent of all messages – translators will go for the simple (which should correlate with most used) messages anyway. That's why I do not see the reason to work on this until we have an updated list.

(In reply to Niklas Laxström from comment #7)

Nemo, I think you are asking me to restore the old list

Not on this bug. :)

(In reply to Niklas Laxström from comment #7)

simple (which should
correlate with most used) messages

I don't see any reason to believe this is true.

[Resetting normal priority according to developer]

Nikerabbit closed this task as Resolved.Feb 18 2015, 6:55 AM
Nikerabbit claimed this task.

New list was deployed to translatewiki.net For practical purposes this is done, but I will file a follow up task to improve the code I wrote.