Page MenuHomePhabricator

PHP Warning: Invalid argument supplied for foreach() in SpecialPageFactory.php
Closed, ResolvedPublic

Description

23 PHP Warning: Invalid argument supplied for foreach() in /usr/local/apache/common-local/php-1.23wmf19/includes/specialpage/SpecialPageFactory.php on line 556
9 PHP Warning: Invalid argument supplied for foreach() in /usr/local/apache/common-local/php-1.23wmf19/includes/specialpage/SpecialPageFactory.php on line 243


Version: 1.23rc
Severity: normal

Details

Reference
bz63497

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz63497.
bzimport added a subscriber: Unknown Object (MLST).
Reedy created this task.Apr 3 2014, 7:19 PM

Reedy: How often does this happen?

Previously this has been caused by a Special page class returning a Message object as its description instead of a string as is expected.

This is still happening in 1.23.0rc0 (the line numbers are just +4)

PHP Warning: Invalid argument supplied for foreach() in /srv/www/mediawiki/public_html/w/includes/specialpage/SpecialPageFactory.php on line 246
PHP Warning: Invalid argument supplied for foreach() in /srv/www/mediawiki/public_html/w/includes/specialpage/SpecialPageFactory.php on line 570

It happens on my wikifarm dozens of times a day. I’m not sure what triggers it.

demon lowered the priority of this task from Normal to Low.Jun 11 2015, 4:35 PM
demon raised the priority of this task from Low to High.
demon lowered the priority of this task from High to Low.
demon added a subscriber: demon.
Alexia added a subscriber: Alexia.Oct 20 2015, 7:18 PM

I believe this was the bug fixed by this pull request and was merged into 1.24+.
https://gerrit.wikimedia.org/r/#/c/59522/

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 20 2015, 7:18 PM
mmodell closed this task as Resolved.Oct 22 2015, 10:48 PM
mmodell claimed this task.

Thanks @Alexia