Page MenuHomePhabricator

Upgrade Wikimedia servers to Ubuntu Trusty (14.04)
Closed, DeclinedPublic

Details

Reference
bz63899

Related Objects

StatusSubtypeAssignedTask
Declinedhashar
ResolvedNone
Resolvedbrion
DeclinedNone
ResolvedKrinkle
Resolvedfgiunchedi
Resolvedakosiaris
Resolvedhashar
Resolvedakosiaris
ResolvedAndrew
ResolvedJoe
Resolvedtstarling
ResolvedJoe
ResolvedJoe
ResolvedJoe
ResolvedJoe
ResolvedDzahn
ResolvedJoe
Duplicatefgiunchedi
Resolvedbrion
Resolvedbrion
Resolvedbd808
ResolvedJoe
DeclinedArielGlenn
ResolvedArielGlenn
Resolvedori
DeclinedNone
ResolvedMoritzMuehlenhoff

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 3:21 AM
bzimport set Reference to bz63899.
bzimport added a subscriber: Unknown Object (MLST).

"There are a couple of external dependencies that, if met, would accelerate our work:

A speedy Ubuntu 14.04 deployment"

https://www.mediawiki.org/wiki/Wikimedia_MediaWiki_Core_Team/Quarterly_review,_April_2014#HHVM

I am pretty sure having an image in labs for 14.04 is a prerequisite. Will let us try the puppet manifest and upgrade the beta cluster before production.

+blocker Bug 60684 - Virtual image for Ubuntu Trusty (14.04)

  • Bug 68190 has been marked as a duplicate of this bug. ***
hashar renamed this task from Upgrade servers to Ubuntu 14.04 to Upgrade Wikimedia servers to Ubuntu Trusty (14.04) (tracking).Nov 25 2014, 2:35 PM
hashar edited projects, added acl*sre-team; removed Wikimedia-General-or-Unknown.
hashar set Security to None.

Wondering what is the status here.
T80945: Get rid of all Ubuntu Lucid (10.04) installs (get rid of 10.04) might block this one?

We are upgrading some to Debian Jessie already instead.

Wondering what is the status here.
T80945: Get rid of all Ubuntu Lucid (10.04) installs (get rid of 10.04) might block this one?

The other one is unresolved but i would not call it a blocker.

How much of this can be "to Debian jessie" right away without going through an additional step?

Closing this ticket, it's currently not really useful/duplicated. We already have a tracking ticket to get rid of precise and our preferred default distro is jessie.

Phabricator_maintenance renamed this task from Upgrade Wikimedia servers to Ubuntu Trusty (14.04) (tracking) to Upgrade Wikimedia servers to Ubuntu Trusty (14.04).Aug 13 2016, 9:33 PM