Page MenuHomePhabricator

Fatal error: Declaration of ProofreadPageContent::preloadTransform() must be compatible with that of Content::preloadTransform() in ProofreadPageContent.php on line 262
Closed, ResolvedPublic

Description

[2014-04-15 18:43:48] Fatal error: Declaration of ProofreadPageContent::preloadTransform() must be compatible with that of Content::preloadTransform() at /usr/local/apache/common-local/php-1.23wmf22/extensions/ProofreadPage/includes/page/ProofreadPageContent.php on line 25
Server: mw1196
Method: GET
URL: http://wikisource.org/w/api.php?hidebots=1&days=7&limit=50&action=feedrecentchanges&feedformat=atom
Cookie:
Backtrace:
#0 /usr/local/apache/common-local/php-1.23wmf22/extensions/ProofreadPage/includes/page/ProofreadPageContent.php(25): unknown()
#1 /usr/local/apache/common-local/php-1.23wmf22/includes/AutoLoader.php(1251): require('/usr/local/apac...')
#2 [internal function]: AutoLoader::autoload('ProofreadPageCo...')
#3 /usr/local/apache/common-local/php-1.23wmf22/extensions/ProofreadPage/includes/page/ProofreadPageContentHandler.php(87): spl_autoload_call('ProofreadPageCo...')
#4 /usr/local/apache/common-local/php-1.23wmf22/includes/Revision.php(1061): ProofreadPageContentHandler->unserializeContent('<noinclude><pag...', 'text/x-wiki')
#5 /usr/local/apache/common-local/php-1.23wmf22/includes/Revision.php(1009): Revision->getContentInternal()
#6 /usr/local/apache/common-local/php-1.23wmf22/includes/FeedUtils.php(177): Revision->getContent()
#7 /usr/local/apache/common-local/php-1.23wmf22/includes/FeedUtils.php(91): FeedUtils::formatDiffRow(Object(Title), '0', '383732', '20140415124513', '/* Not proofrea...', '')
#8 /usr/local/apache/common-local/php-1.23wmf22/includes/ChangesFeed.php(227): FeedUtils::formatDiff(Object(stdClass))
#9 /usr/local/apache/common-local/php-1.23wmf22/includes/api/ApiFeedRecentChanges.php(73): ChangesFeed::buildItems(Object(ResultWrapper))
#10 /usr/local/apache/common-local/php-1.23wmf22/includes/api/ApiMain.php(910): ApiFeedRecentChanges->execute()
#11 /usr/local/apache/common-local/php-1.23wmf22/includes/api/ApiMain.php(363): ApiMain->executeAction()
#12 /usr/local/apache/common-local/php-1.23wmf22/includes/api/ApiMain.php(334): ApiMain->executeActionWithErrorHandling()
#13 /usr/local/apache/common-local/php-1.23wmf22/api.php(85): ApiMain->execute()
#14 /usr/local/apache/common-local/w/api.php(3): require('/usr/local/apac...')
#15 {main}


Version: REL1_23-branch
Severity: major

Details

Reference
bz63958

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:25 AM
bzimport added a project: ProofreadPage.
bzimport set Reference to bz63958.
bzimport added a subscriber: Unknown Object (MLST).
Reedy created this task.Apr 15 2014, 6:45 PM

Change 126045 had a related patch set uploaded by Reedy:
Declaration of ProofreadPageContent::preloadTransform() must be compatible with that of Content::preloadTransform().

https://gerrit.wikimedia.org/r/126045

Change 126045 merged by jenkins-bot:
Declaration of ProofreadPageContent::preloadTransform() must be compatible with that of Content::preloadTransform().

https://gerrit.wikimedia.org/r/126045

Change 126049 had a related patch set uploaded by Reedy:
Declaration of ProofreadPageContent::preloadTransform() must be compatible with that of Content::preloadTransform().

https://gerrit.wikimedia.org/r/126049

Change 126049 merged by jenkins-bot:
Declaration of ProofreadPageContent::preloadTransform() must be compatible with that of Content::preloadTransform().

https://gerrit.wikimedia.org/r/126049

  • Bug 63957 has been marked as a duplicate of this bug. ***

For reference, originally caused by 730c2c01

No Gerrit patches left; is there more work to be done?

Tpt added a comment.Apr 17 2014, 11:53 AM

I believe that the change I8b53327c9e0108cee54d91eb7e35382daffe7bd6 has solved the issue.

Change 135280 had a related patch set uploaded by Scnd:
Declaration of ProofreadPageContent::preloadTransform() must be

https://gerrit.wikimedia.org/r/135280

Change 135280 abandoned by Krinkle:
Declaration of ProofreadPageContent::preloadTransform() must be

Reason:
Duplicate of 3e202b9.

https://gerrit.wikimedia.org/r/135280

Change 135547 had a related patch set uploaded by Krinkle:
Declaration of ProofreadPageContent::preloadTransform() must be compatible with that of Content::preloadTransform().

https://gerrit.wikimedia.org/r/135547

Change 135547 merged by jenkins-bot:
Declaration of ProofreadPageContent::preloadTransform() must be compatible with that of Content::preloadTransform().

https://gerrit.wikimedia.org/r/135547

GOIII moved this task from Backlog to Done on the ProofreadPage board.Jun 12 2016, 3:56 AM