Page MenuHomePhabricator

Graph waiting time for shell access requests
Closed, InvalidPublic

Description

Users who register at wikitech automatically request shell access rights for Wikimedia Labs (cf. https://wikitech.wikimedia.org/w/index.php?title=Special:Ask&q=[[Category%3AShell+Access+Requests]][[Is+Completed%3A%3Afalse]]&p=format%3Dtemplate%2Flink%3Dall%2Fheaders%3Dshow%2Fsearchlabel%3DOutstanding-20Requests%2Fdefault%3D%28no-20outstanding-20requests%29%2Ftemplate%3DShell-20Request%2Fintrotemplate%3DShell-20Request-2Fhead%2Foutrotemplate%3DShell-20Request-2Ffoot&po=%3FShell+Request+User+Name%0A%3FShell+Justification%0A%3FModification+date%0A&sort=Modification+date&order=asc&eq=no). These are then processed by a wikitech user of the "shellmanagers" group.

It would be nice to graph how long users have to wait for their request to be processed.

The simplest query would be to go to the above link, click "Edit query", remove anything but "?Modification date" from "Additional data to display", choose "JSON export" (or whatever) as "Format as:", set "limit:" to 1 and click "Find results".

This should produce (a repeatable link to) a JSON (or whatever) file. If there are no records in the results, the processing time is 0, otherwise the difference between time() and the "Modification date" printout.

For historical data (which I don't think is needed at the moment), this gets more complicated as you would have to iterate over all pages in the shell requests category that are not open requests, if there are only two revisions in the page history, the processing time is the difference in the revision timestamps, otherwise you would have to go forwards in the revision history from the second revision on and parse the wikitext to see if the parameter "Is Completed" is set positively until you find the first one.


Version: unspecified
Severity: enhancement

Details

Reference
bz64702

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:22 AM
bzimport set Reference to bz64702.
bzimport added a subscriber: Unknown Object (MLST).
scfc created this task.May 1 2014, 10:21 AM
Qgil triaged this task as Low priority.Jan 8 2015, 11:00 AM

What is the motivation of this metric? If the problem is that requests are taking too long to be processed, maybe the first thing to do should be to look at the process itself.

scfc added a comment.Jan 8 2015, 7:47 PM

The motivation of this metric is to see if there is a problem?

Qgil added a comment.Jan 8 2015, 9:09 PM

Has anybody reported a problem? I mean, the shell request process is so linear and affects relatively few people. If there is a problem I guess someone will complain sooner or later. I'm not following those requests, and this is why I'm wondering whether there is any problem to be solved there.

scfc added a comment.EditedJan 9 2015, 4:57 AM

I don't quite understand why there needs to have been a problem in the past to ensure that there is not any in the present (or future).

For shell access requests, we advertise "periodical" processing at https://wikitech.wikimedia.org/wiki/Help:Contents#Requesting_Shell_Access, and for Tools access requests we state that "requests for access are generally dealt with within the day (often faster), though response-time may be longer depending on admin availability" at https://wikitech.wikimedia.org/wiki/Help:Tool_Labs#Getting_access_to_Tool_Labs. What does "periodical" mean? Do waiting times correlate with European sunlight? Western holidays? If someone would complain about the waiting time for his request, would we need to feel ashamed because he is right and we didn't do a proper job or would we be able to state with confidence that waiting times have not exceeded x hours in the past? Those are my primary motivations for this metric.

Qgil lowered the priority of this task from Low to Lowest.Jan 9 2015, 12:44 PM

Well, it is a matter of priorities. I'd rather focus on areas that we know are problematic and benefit from metrics, like T78768: Agree on and implement actions to prioritize code review of patches submitted by volunteers or T78639: How to address the long tail of low priority tasks in active projects.

So no objection to you or anybody else pursuing this task, but I will set priority accordingly.

Acs moved this task from Ready to Go to Doing on the wikimedia.biterg.io board.Feb 16 2015, 5:49 PM
Acs moved this task from Doing to Ready to Go on the wikimedia.biterg.io board.
scfc closed this task as Invalid.Aug 28 2015, 7:31 PM
scfc claimed this task.

In Cloud-Services, shell access is now effectively only given out when a user joins a Labs project (but implicitly in that case), so the waiting time for shell access requests is no longer truly meaningful.