Page MenuHomePhabricator

[Compact links] Collapsed language links should preserve <a>, <li> elements and attributes
Closed, ResolvedPublic

Description

Making elements in the ULS actual <a> links will allow right-clicking to open the article in a new tab. Been requested on the Talk page.


Version: unspecified
Severity: normal
See Also:

Details

Reference
bz64797

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:11 AM
bzimport set Reference to bz64797.
bzimport added a subscriber: Unknown Object (MLST).
Niharika created this task.May 3 2014, 1:43 PM

Also, all the original a tag attributes need to be preserved, so that I can e.g. hover a language name and see the link in the status bar as well as the localised language name in the hover text.

Change 156184 had a related patch set uploaded by Eranroz:
Fix for bug 64797 - set href for langlinks

https://gerrit.wikimedia.org/r/156184

Is this for the language links in the compact links or for the all the language links displayed in ULS panel?

(In reply to Santhosh Thottingal from comment #3)

Is this for the language links in the compact links or for the all the
language links displayed in ULS panel?

For all the links in the ULS panel. The bug description is incorrect, the panel links are already <a> elements, but they need an href attribute to allow them to be opened in a new tab.

The compact language links on side bar is still broken as it isn't possible to open them in new tab. Please review the patch:
https://github.com/wikimedia/jquery.uls/pull/158
https://gerrit.wikimedia.org/r/156184

To make badges ([[m:Wikidata/Development/Badges]]) work, however, preserving the <li> elements would also be needed (confirmed by Bene*): is that within the scope of this bug, or something to file separately?

Change 156184 had a related patch set uploaded by Santhosh:
Compact links: Set href for langugage links in ULS panel

https://gerrit.wikimedia.org/r/156184

Change 156184 merged by jenkins-bot:
Compact links: Set href for langugage links in ULS panel

https://gerrit.wikimedia.org/r/156184

All patches mentioned in this report were merged or abandoned - is there more work left to do here (if yes: please reset the bug report status to NEW or ASSIGNED), or can you close this ticket as RESOLVED FIXED?

We also need to "inherit" <li> attributes...

Jdforrester-WMF set Security to None.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Removing from MW-1.24-release because this isn't going to be fixed in the next few months' worth of security point releases.

jayvdb added a subscriber: jayvdb.Jun 20 2015, 6:09 AM
He7d3r updated the task description. (Show Details)Jul 6 2015, 12:32 PM
Nemo_bis closed this task as Resolved.Dec 11 2015, 12:09 PM
Nemo_bis claimed this task.

Looks good now I think: I can

  • see badges in the sidebar (though not in the ULS panel),
  • right click links in the ULS panel to open them in new tabs etc.,
  • hover links in the ULS panel to see them in the status bar.

Better file additional issues separately.