Page MenuHomePhabricator

implement -wait option for checkimages.py
Closed, ResolvedPublic

Description

It can be added throguh this way (needs some works):
This is the code for core

  1. if len(arg) == 5:
  2. waitTime = int(pywikibot.input(
  3. u'How many time do you want to wait before checking the '
  4. u'files?'))
  5. elif len(arg) > 5:
  6. waitTime = int(arg[6:])

Version: core-(2.0)
Severity: enhancement

Details

Reference
bz65136

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 22 2014, 3:16 AM
bzimport set Reference to bz65136.

Amir, is that all that is needed? Why were these lines commented out?

(In reply to John Mark Vandenberg from comment #1)

Amir, is that all that is needed? Why were these lines commented out?

No, it isnt all that is needed.

The problem is that the method wait() uses a few methods which havent been ported to core.

gerritbot added a subscriber: gerritbot.

Change 189232 had a related patch set uploaded (by Xqt):
Implement -wait option for checkimage.py

https://gerrit.wikimedia.org/r/189232

Patch-For-Review

Xqt closed this task as Resolved.Feb 18 2015, 3:07 AM