VisualEditor: If you open the image inspector, and the image doesn't have a type specified (like thumb), then you can't get out again
Closed, ResolvedPublic

Description

Steps to Reproduce:

  1. Create a page that contains at least one image with no thumb or similar file specification, e.g.,

[[File:Example.jpg|Here's an image.]]

  1. Open the page in VisualEditor.
  1. Select the image and open the image inspector.
  1. Try to get out of the image inspector.

Actual Results:
The "Advanced settings" pane in the image inspector has a spinning death spiral and the error message, "Size values are invalid. Could not retrieve original file size."

The X to close the image inspector does not respond.

Reproducible: Always

This was first reported by Magioladitis for the pdf's listed here: https://el.wikipedia.org/w/index.php?oldid=4650532#.CE.94.CE.B9.CE.B1.CE.BB.CE.AD.CE.BE.CE.B5.CE.B9.CF.82


Version: unspecified
Severity: normal

bzimport set Reference to bz65166.
Whatamidoing-WMF created this task.Via LegacyMay 10 2014, 10:05 PM
Mooeypoo added a comment.Via ConduitMay 12 2014, 5:02 PM

This image is rendered as an inline image and the dialog, at the moment, won't edit it at all. The editing capability for inline images is introduced in the upcoming (big) change for the Image Model.

I've tried to reproduce the bug in both local master and in betalabs and the image doesn't let me open the edit dialog (as expected)

See here: http://en.wikipedia.beta.wmflabs.org/wiki/2014_May_11_TestImageBug?veaction=edit

Am I missing something?

liangent added a comment.Via ConduitMay 12 2014, 5:08 PM

(In reply to Moriel Schottlender from comment #1)

This image is rendered as an inline image and the dialog, at the moment,
won't edit it at all. The editing capability for inline images is introduced
in the upcoming (big) change for the Image Model.

I've tried to reproduce the bug in both local master and in betalabs and the
image doesn't let me open the edit dialog (as expected)

See here:
http://en.wikipedia.beta.wmflabs.org/wiki/
2014_May_11_TestImageBug?veaction=edit

Am I missing something?

Double clicking the image opens the "Media settings" dialog for me.

Mooeypoo added a comment.Via ConduitMay 12 2014, 5:11 PM

Okay I just realized a huge bug: The image dialog popup/button doesn't appear (because it shouldn't yet) but double-clicking opens the media edit dialog.

And since the image is inline, the dialog is not ready to handle it, the dialog then crashes.

This seems to be a double-click bug; WhatamIdoing can you approve that this is how you opened the dialog?

Whatamidoing-WMF added a comment.Via ConduitMay 12 2014, 6:18 PM

Not exactly: I selected it and pressed the Return key. It has the same effect.

Etonkovidova closed this task as "Resolved".Via WebWed, Feb 18, 12:34 AM
Etonkovidova set Security to None.

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.