Page MenuHomePhabricator

httplib2: upgrade repo to 0.9
Closed, ResolvedPublic

Description

https://github.com/jcgregorio/httplib2/releases/tag/v0.9 contains a cacert.txt that /does/ work for WMF domains, so we should:

  • update externals/httplib2 to 0.9, and
  • update setup.py to require httplib2 >= 0.9

Version: core-(2.0)
Severity: enhancement
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=68794

Details

Reference
bz65189

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:19 AM
bzimport set Reference to bz65189.
bzimport added a subscriber: Unknown Object (????).

Change 138774 had a related patch set uploaded by John Vandenberg:
Add soft dependency on httplib2 0.9.0 for cacerts

https://gerrit.wikimedia.org/r/138774

Change 138774 merged by jenkins-bot:
Add soft dependency on httplib2 0.9.0 for cacerts

https://gerrit.wikimedia.org/r/138774