Page MenuHomePhabricator

Can't edit list of users
Closed, DeclinedPublic

Description

It seems that Wikimetrics can't alter cohort, making it inconvenient for real use. In Thai Wikipedia, for example, we have a number of special volunteers that will contribute to the project, and we want to track their changes. The number of these special volunteers are not constant. Therefore, every time a new volunteer appears we have to create a new cohort. This is very ineffective. Making Wikimetrics can edit list of users would solve the problem.


Version: unspecified
Severity: normal

Details

Reference
bz65208

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 3:20 AM
bzimport set Reference to bz65208.
bzimport added a subscriber: Unknown Object (MLST).

Wikimetrics was designed to track a constant list of users over time (such as the users from a specific edit-a-thon) so this hasn't been a highly request feature.

We'll prioritize later this week.

-Toby

From @TFlanagan-WMF, there are a few more usecases:

  • Deleting an invalid username and adding the valid one without having to upload a whole new cohort
  • Handling renamed users--currently, in order to continue getting the same data when a user renames, wikimetrics users must upload a new cohort that includes the new username, re-enter all report parameters, and generate a new report/set of reports.
QChris removed a subscriber: QChris.Mar 25 2015, 10:08 AM
mforns closed this task as Declined.Mar 26 2019, 2:09 PM
mforns added a subscriber: mforns.

Declining because Wikimetrics is being discontinued. See: T211835.

Restricted Application added a project: Analytics. · View Herald TranscriptMar 26 2019, 2:09 PM