Page MenuHomePhabricator

Enable Extension:Babel's category on Czech Wikiversity
Closed, ResolvedPublic

Description

Per community concensus I would like to ask to enable categories for "Extension:Babel", which is deployed on Czech Wikiversity.

We used to have categories by language skill at the times of template:Babel, but with this extension, they disappered so we would like to have them back.

Local project discussions

Details

Reference
bz65211
Related Gerrit Patches:
operations/mediawiki-config : masterEnable Extension:Babel's category on cswikiversity

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 3:20 AM
bzimport set Reference to bz65211.
Juandev created this task.May 12 2014, 5:37 AM

Do you want to use English names for the categories, or Czech ones?

We can either use:

'0' => 'User %code%-0',

or

'0' => 'Uživatel %code%-0',

and so on.

(In reply to Tomasz W. Kozlowski from comment #1)

Do you want to use English names for the categories, or Czech ones?
We can either use:

'0' => 'User %code%-0',

or

'0' => 'Uživatel %code%-0',

and so on.

None. The names haven't been set yet.

Please do not unassign me from this bug without first consulting it with me. Thank you!

Re-assigning to Danny after a nice little chat about ways and means.

(In reply to Tomasz W. Kozlowski from comment #1)

Do you want to use English names for the categories, or Czech ones?
We can either use:

'0' => 'User %code%-0',

or

'0' => 'Uživatel %code%-0',

and so on.

I am sorry for Danny B. Tomasz. I will ask the community and let you know.

(In reply to Juan de Vojníkov from comment #5)

(In reply to Tomasz W. Kozlowski from comment #1)

Do you want to use English names for the categories, or Czech ones?
We can either use:

'0' => 'User %code%-0',

or

'0' => 'Uživatel %code%-0',

and so on.

I am sorry for Danny B. Tomasz. I will ask the community and let you know.

OK, now I read to the end, it was assigned again to Danny B. But it doesnt change nothing. We will talk about it localy and we will let you know.

What's the state of this bug?

(In reply to Tomasz W. Kozlowski from comment #7)

What's the state of this bug?

There is a discussion at the local wiki, about it as I previously said.

So, after the discussion within the community[1], we would prefer

'0' => 'Uživatel %code%-0',

categories.

[1] https://cs.wikiversity.org/wiki/Wikiverzita:Diskusn%C3%AD_prostor#Koment.C3.A1.C5.99e_.28Babel.29

There is no consensus on such naming. Neither on any other. Besides that, there are even some reservations against having those categories at all. Until there will be consensus, this will remain open.

(In reply to Danny B. from comment #10)
Besides that,

there are even some reservations against having those categories at all.

Of course, they are. But the consensus, was to set up them. Anyway, lets continue in cs.wv.

What's the state of this bug?

Seems just be a patch now. Consensus exists for babel and looking at it, Czech names. I do note the assignee of the bug opposes the enabling of babel categories (from what I can see).

(In reply to John F. Lewis from comment #13)

Seems just be a patch now. Consensus exists for babel and looking at it,
Czech names. I do note the assignee of the bug opposes the enabling of babel
categories (from what I can see).

Nope, you are actually not correct. I am actually neutral in enabling. Both sides have reasonable arguments. I just noted here for the record, that there are objections and reservations to enabling. Sorry if I made you confused by possibly ambiguous wording.

Anyway, the only consensus there is that the names should be in Czech. However, there is no consensus on the format of them, hence why it is not closed yet.

I am actually neutral in enabling.... I just noted here for the record, that there are objections and reservations to enabling.

No, you are not neutral. Thats why I am not happy Tomasz W. Kozlowski re-assign this bug to you. You want to push your way to do this, thats why you are talking about objections. JAn Dudik on cs.wv wrote:

"A pokud přesto ty kategorie chcete, nechte si zavést takový název, který bude vyhovovat všem stranám - vám na názvu až tak nezáleží, jen když kategorie budou, a pro Dannyho účely budou v jím preferovaném tvaru Uživatelé:xx-1. JAn Dudík (diskuse) 22. 5. 2014, 19:33 (UTC)"

ENGLISH: "If you want those categories anyway, ask for the name, which will be acceptible for all parties - in fact you dont mind, how it will be called, you only need it, and format "Uživatelé:xx-1" will be prefered by Danny B. and usefull for his purpose." (btw, do feel that sense of manipulation from this comment?)

So basically Danny B. should not be assignee of this bug, because he is here in the "conflict of interest".


Personally I dont mind, how it will be called. The problem is how people proposing the version "Uživatelé:xx-1" push it. They come to the discussion late and they are not big contributors to the project.
*user:JAn Dudík
Proposal: against categories, but if so, than "Uživatelé:xx-1"
Agrument: Danny B. needs it
*user:Milda:
Proposal: against categories, but if so, than "Uživatelé:vlastnost"
Argument: its natural and its used for more than 10 years on WMF projects
Milda things that we want categories for foreigners, but its not correct, he probably havent red well the supporting votes. Btw, >10 years on which projects?
*user:Danny B.:
Proposal: strong oppose, but if so, "Uživatelé:vlastnost"
Argument: no argument
*user:Tchoř:
Proposal: dont mind, but if so, "Uživatelé:vlastnost"
**Argument: the argument of user:Milda is good

So as it was blocked here by Danny B., I think we have to discuss localy about the next steps and it will take some time.

(In reply to Juan de Vojníkov from comment #15)

I am actually neutral in enabling.... I just noted here for the record, that there are objections and reservations to enabling.

No, you are not neutral. Thats why I am not happy Tomasz W. Kozlowski
re-assign this bug to you. You want to push your way to do this, thats why
you are talking about objections.

There *are* actually objections:
https://cs.wikiversity.org/w/index.php?title=Wikiverzita:Diskusn%C3%AD_prostor&diff=49051&oldid=48979
https://cs.wikiversity.org/w/index.php?title=Wikiverzita:Diskusn%C3%AD_prostor&diff=48976&oldid=48975
(and I don't count those stated elsewhere by users who rejected to interfere in discussions with you)

And no, I don't want to push it any particular way, but just the consensus one. And that hasn't been reached yet.

Personally I dont mind, how it will be called.

This is the (new) statement you should actually put on the community discussion page for the record, not here.

Please cite people accurately, completely and without changing the meaning of their words or even the words themselves which gives readers totally different view on the situation than the reality actually is. Feel free to use Google translate for that. Thank you.

So as it was blocked here by Danny B., I think we have to discuss localy
about the next steps and it will take some time.

Nothing is blocked, furthermore not by me. We are simply waiting for the consensus on the naming, which - according to your new statement above - seems to be closer now, so again, please state it for the record on the community discussion page. Thank you.

tomasz removed a project: Shell.Feb 23 2015, 7:58 PM
tomasz set Security to None.
Dereckson updated the task description. (Show Details)Apr 26 2015, 11:10 PM

@Juandev Now 6 months have passed, maybe it would be a good idea to raise again the discussion and gather a new consensus, to see if an agreement, more universal than the list time could be reached.

JAnD added a subscriber: JAnD.May 7 2016, 6:39 PM

Indeed.

Did you do it?

Dereckson changed the task status from Open to Stalled.Aug 24 2016, 11:59 PM

@Juandev So please start a discussion or indicate to us you don't need this anymore.

Aklapper closed this task as Declined.Oct 22 2016, 10:22 AM
Aklapper removed Danny_B as the assignee of this task.
Aklapper added a subscriber: Aklapper.

Unfortunately closing this report as no reply has been provided to T67211#2581014 in the last two months.

@Juandev: Please reopen this report (by changing its status) if this is still wanted and if there is consensus. Thanks!

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptOct 22 2016, 10:22 AM
Juandev reopened this task as Open.Nov 16 2016, 6:56 PM

I am sorry, the following statment of Danny B. is just a trolling. That is one of his tactics to stop project changes he (and only he) doent wont. For simmilar trolling he has allready lost his admin and beraucrat rights on Czech Wikiversity.

There is a community consensus as I stated before. The tactic of Danny B. is to deny it and push as at least to the new disscussion hoping, people will not come to the consensus again.

Here I would also like to link you to simillar trolling of Danny B.:
a) I got importer right on cs.wv under community consensus (majority for, Danny B. against). Danny B. lied to steward PetrSymonds there were no consensus and there are objections (which were just bullshit) so steward removed my rights. All the story is here: https://meta.wikimedia.org/wiki/User_talk:PeterSymonds#Rights_removal

b) There was a consensus on cs.wn about something, bug was opened on bugzilla and Danny B., who was against that change, came to bugzilla and trolled the same way so the bugzilla people didnt make the change. (if you need I will try to link it also)

So I would like to ask you, if you could not listen to Danny B. please? He is not a relevant source of information. He is broadly not welcomed by Wikimedia Communites and recently lost his rights on some of them (others cant get rid of him, because they dont have policies on that). He loses rights because of his dictator tech behaviour performing changes, deleting pages without community consensus or even not respecting community proceses and lieing about his actions - eg. loss of adminship on cs.wp, cs.wv, cs.wikt, wikidata, loss of crat rights on cs.wv. If you want to have a full image about Danny B., I can link you to these two pages written in English:
a) Behaviour on en.wikt: https://en.wiktionary.org/w/index.php?limit=50&title=Special%3AContributions&contribs=user&target=Danny+B.&namespace=&tagfilter=&year=2016&month=-1
b) Desysops on Wikidata: https://www.wikidata.org/wiki/Wikidata:Administrators/Confirm_2013/4#Danny_B._.28talk_.E2.80.A2_contribs_.E2.80.A2_logs.29

There is no consensus on such naming. Neither on any other. Besides that, there are even some reservations against having those categories at all. Until there will be consensus, this will remain open.

@Juandev Now 6 months have passed, maybe it would be a good idea to raise again the discussion and gather a new consensus, to see if an agreement, more universal than the list time could be reached.

I am sorry, the community is tired from discussing the issue again and againg just because of trolls, who stops it here. There was a community consensus and its still valid. So proceed, please.

Disclaimer: I've worked with @Danny_B to solve some MediaWiki core tasks, the semantic support available by default or to add semantic CSS identifiant and class in special pages for example.


The Wikimedia system administrators aren't a resolution dispute facility, so we can't really solve issues between project contributors. We require a consensus from the project, but it's not our role to interfere with the local project to decide what is a consensus or not. We can notice issues, like stamps of approval, lack of discussion duration, and consider it's not enough to process the request, but we aren't closing an on wiki discussion to determine if this is or not a consensus, that's something to do at wiki level, not here.

I checked the meta. discussion, the Juandev's rights log, and I can see there are issues between the two contributors, but that's out of scope here. There are onwiki process to solve this kind of issues.

To namecall ''troll'' people with other opinions isn't appropriated. To note a disruptive behavior could be more accurate and polite, assert it's your point of view and not an universal fact even better.

Secondly, independantly of that, I'm somewhat reluctant to base a 2016 configuration on a 2014 consensus, so I'd suggest to reopen a quick discussion, "Is there still a consensus for the <link to the previous>" on the village pump seems to qualify as a quick discussion easy to implement (one paragraph).

Please note we're only asking for local consensus, not a formal RfC (you can require formal RfC if you wish, but that's a project decision to decide the best way to get a consensus)

Regarding the consensus. The link to the consensus of the form of use is here: https://cs.wikiversity.org/wiki/Wikiverzita:Diskusn%C3%AD_prostor/Archiv_2014#Konkr.C3.A9tn.C4.9Bj.C5.A1.C3.AD_hlasov.C3.A1n.C3.AD

And for the issue with Danny B.'s behaviour, I have opened a new task: https://phabricator.wikimedia.org/T150893

Disclaimer: I've worked with @Danny_B to solve some MediaWiki core tasks, the semantic support available by default or to add semantic CSS identifiant and class in special pages for example.

The Wikimedia system administrators aren't a resolution dispute facility, so we can't really solve issues between project contributors. We require a consensus from the project, but it's not our role to interfere with the local project to decide what is a consensus or not. We can notice issues, like stamps of approval, lack of discussion duration, and consider it's not enough to process the request, but we aren't closing an on wiki discussion to determine if this is or not a consensus, that's something to do at wiki level, not here.
I checked the meta. discussion, the Juandev's rights log, and I can see there are issues between the two contributors, but that's out of scope here. There are onwiki process to solve this kind of issues.
To namecall ''troll'' people with other opinions isn't appropriated. To note a disruptive behavior could be more accurate and polite, assert it's your point of view and not an universal fact even better.
Secondly, independantly of that, I'm somewhat reluctant to base a 2016 configuration on a 2014 consensus, so I'd suggest to reopen a quick discussion, "Is there still a consensus for the <link to the previous>" on the village pump seems to qualify as a quick discussion easy to implement (one paragraph).
Please note we're only asking for local consensus, not a formal RfC (you can require formal RfC if you wish, but that's a project decision to decide the best way to get a consensus)

Well, we may open the discussion again. But if Danny B. will deny it? Will you decline it again? We already came into a consensus 2 times. Is that not enough? On Wikipedia or whatever other project consensus last till another consensus came.

In this case, I would wait to the result of that behavioral task/request I made and than we can if needed take it back to the project, weather the community show the will to have it.

My only concern was 2014 vs. 2016 here, not the opposition of one contributor.

[offtopic] @Juandev: In reply to T67211#2800155, please respect and follow the Phabricator Etiquette in the future. Thank you for keeping Phabricator a respectful place.

My only concern was 2014 vs. 2016 here, not the opposition of one contributor.

The delay was done on the site of developers, not on the site of Czech Wikiversity community. I am only afraid of the same situation as before. We can talk about it again locally and if we agree, Danny B. can again question this agreement. This problem was open on Czech Wikiversity for more than two month. Danny B. was directly questioned 3 times, but he hadnt left any coment even he was active at the moment: https://cs.wikiversity.org/wiki/Diskuse_s_u%C5%BEivatelem:Danny_B./Archiv/2014#U.C5.BEivatel.C3.A9_podle_jazyka

@Juandev Now 6 months have passed, maybe it would be a good idea to raise again the discussion and gather a new consensus, to see if an agreement, more universal than the list time could be reached.

Hi, could you proceed this request. We have discused the issue again and came to the same agreement as we did before.

Mmh added a subscriber: Mmh.Jan 5 2017, 11:31 PM

As an admin and bureaucrat on cs.wv, I confirm the consensus of the community Juandev mentioned above.

Urbanecm claimed this task.Jan 6 2017, 5:27 AM
Urbanecm added a subscriber: Urbanecm.

As a bureaucrat said community really agree with enabling and I also see some consensus as Czech native speaker I'll process this.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptJan 6 2017, 5:27 AM

Change 330847 had a related patch set uploaded (by Urbanecm):
Enable Extension:Babel's category on cswikiversity

https://gerrit.wikimedia.org/r/330847

Consensus reached per the bureaucrat.

Scheduled for Monday, 14:00 - 15:00 UTC (15:00 - 16:00 CET).

Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.

Change 330847 merged by jenkins-bot:
Enable Extension:Babel's category on cswikiversity

https://gerrit.wikimedia.org/r/330847

Mentioned in SAL (#wikimedia-operations) [2017-01-09T14:52:03Z] <zfilipin@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:330847|Enable Extension:Babel s category on cswikiversity (T67211)]] (duration: 02m 36s)

Urbanecm closed this task as Resolved.Jan 9 2017, 2:53 PM

Deployed.