Page MenuHomePhabricator

UploadWizard: Flickr uploading broken - browser redirect the user to the result of the API request
Closed, ResolvedPublic

Description

Instead of sending an AJAX request, the browser redirect the user to the result of the API request

The feature is completely broken. It was reported under https://commons.wikimedia.org/wiki/Commons:Village_pump#Anyone_else_having_problems_with_Flickr_uploads_.3F


Version: unspecified
Severity: major
URL: https://commons.wikimedia.org/wiki/Commons:Village_pump#Anyone_else_having_problems_with_Flickr_uploads_.3F

Details

Reference
bz65406

Event Timeline

bzimport raised the priority of this task from to Unbreak Now!.Nov 22 2014, 3:17 AM
bzimport added a project: UploadWizard.
bzimport set Reference to bz65406.
Rillke created this task.May 16 2014, 5:56 PM

So here is what I found out so far:

  • It is using IframeTransport for Flickr upload -- Why the hell? It's just upload-by-url; this could be a normal POST request of either the ActiveX component or the standard XHR (which is both normalized by $.ajax)
  • It doesn't set the target of the form -- so it submits to the page instead of the iframe

Change 133844 had a related patch set uploaded by Rillke:
Wait until iframe is fully loaded before submitting form

https://gerrit.wikimedia.org/r/133844

Follow-up:
Bug 65423 - UploadWizard should not use iframe transport for upload_by_url requests to the wiki-own-API (FlickrUploading)

cometstyles wrote:

Any updates on this? Its a widely used feature on commons and probably the most useful...

(In reply to Cometstyles from comment #5)

Any updates on this?

It's awaiting code review. Go to #wikimedia-multimedia and nag there.

Change 133844 merged by jenkins-bot:
Wait until iframe is fully loaded before submitting form

https://gerrit.wikimedia.org/r/133844

Patch was merged yesterday - is there more work left to do here (if yes: please reset the bug report status to NEW or ASSIGNED), or can you close this ticket as RESOLVED FIXED?

(In reply to Andre Klapper from comment #8)
Is there a reason we have not a resolved deployed ? Sure MW is also used by other parties but WMF wikis are the most important customer, I think.

cometstyles wrote:

I still get this (http://i.imgur.com/yNgeWbE.png) and get redirected to this page (http://commons.wikimedia.org/w/api.php) when i click "Leave this page"..its still very much broken..

(In reply to Cometstyles from comment #10)
Of course you get because it's not yet deployed. But Andre Klapper is urging me to close bugs as soon as I features are fixed in core. The issue is that this Bugzilla ticket is not for deployment of the fixed version but to get the fix into the code repository of UploadWizard.

According to [[:mw:MediaWiki_1.24/Roadmap]], the new version will be deployed today to Commons :)

FIXED means fixed in the code base. FIXED does not mean deployed on the servers. https://www.mediawiki.org/wiki/Bug_management/Bug_report_life_cycle

Tgr added a comment.May 20 2014, 5:34 PM

Maybe something to revisit after the Phabricator switch as the bug tracker and the version control system is connected much more closely there so tracking deploy status is probably easier to do.

No, this isn't deployed yet :( so it will be on Tuesday, 27 May 2014

Tgr added a comment.May 20 2014, 8:41 PM

What is the impact of this bug? We could do a backmerge if it affects a lot of uploads.

What is the impact of this bug? We could do a backmerge if it affects a lot of
uploads.

  1. The feature is completely broken for browser other than IE 11.
  2. There are alternative means of uploading from Flickr involving servers on Labs.
  3. 11'187 files have been uploaded using this feature so far. Note that it was implemented in 07/2012 but enabled/ prepared to be enabled on 2012-11-13.
Tgr added a comment.May 20 2014, 9:51 PM

That's about 20 images a day. We probably should not use a SWAT deploy for something like that.

Change 141208 had a related patch set uploaded by Inchikutty:
Wait until iframe is fully loaded before submitting form

https://gerrit.wikimedia.org/r/141208

Change 141208 abandoned by Alex Monk:
Wait until iframe is fully loaded before submitting form

https://gerrit.wikimedia.org/r/141208

[Restoring previous FIXED status]

Gilles moved this task from Untriaged to Done on the Multimedia board.Dec 4 2014, 10:10 AM